Servers by jDrones

Arming problem and need help

Ok, so actually it seems I really do not have much of a linear throttle. The motors dont seem to increase in RPM very much from low stick. The THR_MAX is 900, MID 380, MIN 100, TRIM_THR 200. I also have the MOT_SPIN_ARMED set at a value of 1 but the motors do not spin upon arming.

I noticed within the ESC Calibration field there is a section related to setting MAX, MIN, LOW throttle values but the boxes to do this do not light up and wont let me into those fields to change the values. How do I set the throttle settings to run from low to higher RPM?

Min should be like 980, mid 1500 and max 1900

Inside Mission planner go to Servo settings and change them. re caliberate your radio.

What radio are u using?

Disregard my message above, I figured it out after reading into your message slightly more. This is the first APM I have had so many issues with. I guess its all about how they get to you and what parameters are already preset. Setting up an airplane within APM is slightly easier to do in my opinion.
My next investment will be a Pixhawk. Do they set up the same as the APM boards or are they a little more user friendly?

Same as APM but much more reliable…

I am using a Spektrum DX8 with AR8000 DSMX receiver.

The THR parameters are not the servo output settings and further those settings don’t even exist in the level of Arducopter firmware he is using. This is what he will see from the Servo Output screen:

When set a new model don’t change Any default PWM values.

Hey guys, hope everyone is doing well. I thought I was ready for spooling it up and see what happens as far as a first flight. When it got light on the skids it wanted to come backwards quite quickly so I shut it down…skids grabbed in the grass and it halfway toppled over…no damage.
I’ve checked the rotation of motors and made sure I have the right props on the right motors. Everything checked out fine.
Can anyone offer some advice as to what I should check? Thanks!

Were you giving it pitch input to attempt to counteract this? If so reverse the pitch channel (2) in your transmitter. This is common. Otherwise don’t baby it on Takeoff. Give it a burst of throttle to get it off the ground.

Yes, I was giving it forward elevator stick to counteract its tendency to want to walk backwards towards me. And yes I was babying it just to see what it was going to do. It checks out fine on the RC Input checks and the movement is in the correct directions. Should I still reverse it like you mention? Even if it still checked out like it should within Mission Planner?

Thanks for your reply, much appreciated!

Yes, reverse pitch on your transmitter and give it another go. But just to besure. Your Transmitter trim sliders are at center when you did the Radio Calibration (and never change them) and you have done a proper accelerometer calibration?

OK, so i did another accelerometer calibration and gave it a try. I do not have motors start on arming even though I gave is a value slightly above minimum throttle. Not a big deal but I would like to have motors run when armed so its consistent with my other F550 with a Naza sysem.
So when I gave it a go this time at low throttle it wanted to do the same thing again however you mentioned to bump it into the air and not mess around on the ground. When I did this the F450 did go straight up I was able to slightly control it and it was responding and flying one spot. The real problem I am having is my throttle is not linear. It seems to have full throttle at half throttle with no change in rpm after half throttle.
I want the throttle to be smooth from zero stick to full stick…how do I achieve that?

You must be in an Altitude Hold mode (AltHold, Loiter, PosHold) for it to perform that way (as it should). Mid throttle is Hover position in those modes Takeoff in Stabilize mode and once it’s a few feet off the ground switch to an assisted mode if you want. Just realize that you have full control of the throttle it will only stabilize attitude not altitude or position.

You should read the Wiki for the available flight modes.
https://ardupilot.org/copter/docs/flight-modes.html

Increase the MOT_SPIN_ARM parameter to get the props spinning after arming.

I am in stabilize mode, that is what I have set currently on all 3 positions just in case I was to bump it I didn’t want to go into some mode I wasn’t ready for.

As for the throttle stick currently its dangerous to fly as I go from low stick to mid stick I seem to get all the power at once, there is no low range mid range or full throttle. As soon as I move the stick it just goes to a high throttle position.
THR_MAX is 1950
THR_MID is 450
THR_ MIN is 100
Is this acceptable? Do I need to look at another setting that causes the throttle increments to move slower? Like when I move the stick to full throttle it moves through those increments I have set at a slower pace and I don’t get full throttle all at once?

No those are not right. Perhaps you should set all to default and start over. That’s what I would do.From the Full Parameter List press the button that says “Reset to Default”. Then configure everything and re-do all calibrations.

Better yet, get rid of that obsolete flight controller and replace it with one that runs current Arducopter.

Ok, i will just reset it and start over then. I am kinda stuck with the APM right now. Hobby money is tight at the moment to order a Pixhawk or similiar.

Servers by jDrones