Arming error via transmitter - EKF

Hi everyone,

I have a problem arming the motors. Everything looks well. I have the green light of the PixHawk flashing. I do not get any prearming error. The EKF used to be red, even after recalibrating the compass and getting the positive tune after calibrating and rebooting the pixhawk. So I changed a parameter COMPAS_OFFS_MAX to 3000 and now EKF is white (changing this parameter is suggested here:

However, I still can’t arm the motors. I do not get any error messages. The motor just fails to arm. I can arm it via the ground station but not via the transmitter. I am completely stuck with this. I tried everything I could but I can’t arm the motor with my transmitter. If anyone can give any tip how to fix this, or how to proceed to find out what is causing the problem, that would be very welcome :slight_smile:

PS: The transmitter is calibrated and works correctly. If I arm the motors via the groundstation software, then I can make my motors run.

So you can ARM via the Ground station or just able to run the motor test ?
Can you set LOG_DISARMED to 1 and try arm via the transmitter then send the log here ?

I can arm the motor via de ground station but the motor tests are also working fine.

Here is the log you asked for:

Your transmitter is faulty. This is how the RCIN looks like. No surprise it wont arm. RC4 wont stay at max long enough.
This is nothing to do with mission planner. It’s a receiver failure.

I am not really an expert so I don’t understand completely what I am looking at. RC4 … is that the rudder down right to arm ? And how can I fix this issue ? I am holding the rudder down long enough so I guess there must be something wrong with the transmitter and I need to recalibrate it ?

throttle down and rudder right this is the arming. Rudder right is max and due the error it wont stay at max, there are those spikes.
Fortunately you are lucky, because with this RC you will definitely crash within 5 seconds.

It’s not a calibration issue, more likely a faulty receiver. What kind of RX it anyway ?

1 Like

I have a radiolink AT10 and receiver R12DS.

Ok, so the max issue is if you push the rudder left. But arming is right down. So it should arm because that signal is still fine ? I also don’t get any pre arm error on the ground station. The EKF however is red again. So weird because when I put COMPAS_OFFS_MAX to 3000, it was white but now it is red again.

Corrected, arming is rudder right…

The signal is not fine, there is something wrong with the RC signal. And that’s an OLD version of Arducopter.

1 Like

Yes it is an old version but so is my drone. It used to work. I just left it sitting in the garage for more than a year and wanted to use it again but now I get this issue :slight_smile:

Update it to current stable. What protocol are you using with that RC system.

The remote control is PWM but there is a PPM module that converts it.

Why are using a converter? That receiver will output Sbus when configured for it from the Transmitter AFAIK.

Because this is what I got when I bought it. I got a receiver with a PPM converter. And it used to work fine. Never had problems arming the motor. But I need to learn more about how everything works still. I am not as knowledge about how everything works. I don’t even understand how you and Andras both see that the RC signal is wrong. I am basically still a rookie :slight_smile:

That’s OK Joe, everyone is a rookie once. So, I don’t think you need the PWM/PPM converter, it just adds needless complexity. You should be able to eliminate the converter, configure the Receiver thru the Transmitter to output Sbus and connect the Receiver directly to the flight Controller with 1 3-lead servo cable. Do you have the manual for that Radio?

I don’t have the manual but I think I can find it online. It is the radiolink at10.

Well, here is the receiver you have and the Sbus ouput shown. Connect one 3-lead servo cable from there to the RCin connector of the Pixhawk. I think you may have to select the Sbus protocol on the Transmitter before binding the receiver for this mode. Other radios like Flysky work this way.


1 Like

Hey man,

I didn’t have time to do it the past days because I had a deadline for some online course I was doing. Today I finally had time. I used S-bus and it works now. I can arm my motors. I don’t need so many cables now. Thanks a lot for the help :slight_smile:

That’s great Joe! Happy to help and good luck with your studies.

1 Like