Are there ways to limit the throttle of dshot escs?


I am using bl32 escs for main rotor and DDFP tail rotor. The motors was tested before so I know the throttle need to be limited to avoid overcurrent.

However there’s no MOT_SPIN_MAX parameters in heli firmware. I also can’t set SERVOx_MAX because I have to use dshot protocol for esc telemetry.

Any suggestions?

Thanks very much

Hello @ROSStargh welcome back,

You could try to limit the battery current parameter: Current Limiting and Voltage Scaling — Copter documentation

For main rotor, assuming you are using H_RSC_MODE_3 or 4, you need to set H_RSC_THRCRV_75 and 100 so that pwm stays within your limit. Be sure to check your max collective angle value so that you don’t face rpm drop or motor overheat.
For tail rotor, if using DDFP there are this params:

Thank for help

I plan to use H_RSC_MODE 4. In this mode, the flight controller may increase throttle when under load. So I think it’s not guaranteed that the throttle is within H_RSC_THRCRV_100?

There’s no H_DDFP_xxx params in V4.4.3 firmware. I have found it in V4.5.0dev, but I’m not confident to use dev firmware. Is it stable enough to use on a heli?


This might not work because batt current cannot be used to limit the tail throttle individually. And the params MOT_BAT_xxx are not in heli firmware.

That’s why I suggested to thoroughly check your collective at full pitch. That’s the primary source of load (at constant rotor speed), so you want to make sure it’s compatible with your current hardware setup/limits. I suggest to start the setup with pure throttle curve (so H_RSC_MODE_3) , constrain the heli on ground and do collective travels test. If you see rpm dropping at full collective, you either have to reduce H_COL_MAX parameter or increase throttle curve parameter, depending on the monitored Ampere draw. This way you are reasonably safe when you will switch to governor mode.