Servers by jDrones

Are there any actual devs in this forum?

Are there any actual I am writing this out of extreme frustration…

  • I am trying to build a tiltrotor tricopter where all 3 motors tilt
    -the design is 2 meter, efficient, and built of all carbon fiber
    -I am attempting to replicate a build by a guy called kris
    demo of tricopter 3x3
  • I have posted here twice asking for help, some have tried (thank you)
    -I have had NO HELP at all from a dev.

WHY?

is this dev team disbanded or incompetent?
why is ChibiOS not been updated for a year?
why are there no devs in this forum?
why do so many pilots complain of so many crash-causing glitches?
why do I get constant “bad AHRS” messages (px4 doesnt)
why does arming not work correctly?

to those who have tried to help me thank you very much<<<

I will assume no one will answer… just thought I would try one last time.

Jeff

I have no idea of your previous messages but I’ve been here for a long time now, and I’ve been using ardupilot almost from the beginning of it. In answer to your questions:

is this dev team disbanded or incompetent?
Not at all, you can check the activity on github. Every single day there are lots of commits. The code is constantly improving. About them being incompetent, what makes you think so? Besides being my hobby, I’ve been working in the UAV industry for a while also, and I could say Ardupilot is one of the best if not the best autopilot out there, open or closed source.

why is ChibiOS not been updated for a year?
I am not really aware of the current ChibiOS development but, Why is that a problem for you? ChibiOS is just the RTOS of the autopilot. If you have the RTOS working there should be no need to change it. As developer, I’ve never encounter any problem working over ChibiOS. Everything works as it should as far as I know.

why are there no devs in this forum?
There are. But you need to understand this is an open source autopilot. This developers put a lot of their free time on building this autopilot for you to enjoy, and they don’t ask for anything in return. Don’t think it is an obligation for them to also answer all the questions in the forum. Also, as user, I rarely encounter a situation where I can’t get all the information I need from the documentation. Have you really tried to understand everything related to it before asking? This is not a paid commercial support at all, you have to understand that.

why do so many pilots complain of so many crash-causing glitches?
Again, there is a huge percentage of the small-mid size UAV ( even huge ones ) on the industrial UAV industry using Ardupilot. I have myself flown directly or indirectly a huge number of hours under ardupilot. I personally have never experience any autopilot malfunctioning that depended on the firmware. This is a complex autopilot, and you really need to understand a bit the basics for setting up a reliable platform. You can not blame the autopilot firmware if you don’t take care of a clean power supply, noise free wiring, quality hardware, a good setup and tuning/testing, or quality peripherals to name a few.

why do I get constant “bad AHRS” messages (px4 doesnt)
Maybe it has something to do with your particular build? it doesn’t need to be something applicable to the whole project. Ardupilot is able to fly properly and secure under several warnings. Maybe other autopilots don’t give that warnings and just keep flying or, I don’t know. If you get that message that should have an explanation.

why does arming not work correctly?
Again, arming works perfectly. If you can not arm maybe there is something wrong that doesn’t let you arm, there are several reasons for this, and is a security feature. You can always disable it ( arming_bitmask or something like that ). It throws a message of why it doesn’t let you arm, though.

I rarely respond to this kind of messages, but I really get annoyed by them. There are lots of new users that are just googling around and reading some information here and there for helping them decide which autopilot to use. Although there are a huge number of evidence out there supporting the reliability and quality of Ardupilot, this kind of post can just stop some new users for trying Ardupilot, and, using Ardupilot as autopilot is probably the best decision you can make while setting up a reliable, tested, future-proof platform.

I think maybe you should read carefully the wiki, and if you can not find there the feature you need, you can always ask politely for it to be developed. If it is of interest for the project is probably going to be added. Also as it is open source you can add it yourself. If you don’t feel like it, or you really need it done quickly you can pay a developer for adding the feature for you. You can seek for developers able to work on it under the section “commercial support” of the Ardupilot web or on the general forum “wanted-jobs”.

There are lots of example of successful companies using Ardupilot on really serious UAV, companies that could perfectly afford to develop an autopilot themselves, or using a closed source commercial one. If they stick to Ardupilot that have to mean something. You can check the ardupilot partners list to see a few of them. If you are the only one having a problem with it, maybe the autopilot is not the problem.

EDIT: I just read some of your posts. The people that helped you, at least one of them was a developer by the way, guided you very well on what you needed, and were really polite with you.

Instead of being a bit patient and working a bit more on what you needed, you have chosen to speak on a not really polite way, and you can not expect anybody to answer you if you ask anything with that tone. Even less if you are seeking FREE help.

Just for reference, here are some of your posts if somebody reads this, for evaluating if your testimony is a good representation of what the user experience with Ardupilot is.

11 Likes

I believe the answer to nearly all of the questions is “operator error or misunderstanding.” I suggest you start reading the wiki to learn how ArduPlane works at the basic level. A secondary suggestion would be not to insult the people you want to help you, but that’s just my opinion.

2 Likes

The developers here are great, I’ve received unsolicited personal replies from a few of them to really simple questions before. My experience is if you’ve done your homework they’re immensely helpful and gracious, even to noobs like me.

1 Like

Hello,

Thanks you @david_sastre for your clear answer!

@jumpwing I am a dev and I would also add that we are only a few managing the whole ArduPilot eco-system. There are dozen of question everyday so that is hard to us to anwser everybody specially as some can be really tricky to deal with.
Moreover, we also really on the community to help and share experience. There are a lot a people here that help and have better knowledge that some dev. For example, even if I am a dev, I don’t know much about plane and vtol…

About your questions :

  • no the team isn’t disbanded. But we deal with multiple matter, and need to split time between support, infrastructure and development. It is a free time jobs, so our help or answer could come slowly… Incompetent ? Yes, I am on plane
  • I don’t know what part you are speaking about on Chibios ? The hal part received some development mostly every month. Chibios OS part won’t move much as it is already working. So unless we get evidence to upgrade other than a new version is out, it won’t move. On another fact is that most development are going in master branch. Stable release only get bug fixes. New stable versions based on recent master should come soon. We made heavy development and code changes so we are really careful on next stable series (but improvements are huge)
  • people complaining about crash is difficult to deal with. We are always sorry to heard about a crash but we do our best to have reliable software, quality partner hardware and documentation. The real question is what cause the crash ? User issue ? Documentation issue? Software issue ? Or hardware issue ? To much cause of issue but as always most people only post when they are in troubles or to complain… So yes this forum is full of issue questions but also full of cause analysis and help !
  • bad ahrs would generally mean that something is wrong on you parameters. Double check that imu, GPS,compass are rightly setup and calibrated. Follow initial flight instructions carefully. If you still have the issue. Please post a dataflash log (the one on sd card, either get it through a gcs or directly from sd) so anybody can look at both parameter and log to track you issue.
  • please details your arming issue ? We put a lot of safety on arming so if it refuse to arm that generally that you made an error on your setup or in takeoff process !

PS : Now you get a dev anwser ! :stuck_out_tongue_winking_eye: .

2 Likes

Linking to your posts is helpful.
Telling us your firmware version is helpful.

Most of the changes on the RTOS are to support new cpus. The STM32F4 and F7s are pretty stable RTOS-wise. We’ve cherry-picked many upstream changes and also contributed changes back. There have been many changes on our fork, but the majority of upstream changes have not reached the cost/benefit threshold of having to verify that it doesn’t bring down aircraft. Are you volunteering to test a whole RTOS version update on your aircraft?

We’re here. We’re in many places. GitHub, FaceBook, gitter… have you looked at the “community” tab on arudpilot.org?

Citation needed

PX4 doesn’t do a lot of things ArduPilot does. Having more features means more setup. This is typically a setup or calibration problem.

See above.

Such a Debby downer!

Sounds like you’re having troubling getting going with ArduPilot. I suggest getting it working on a cheap aircraft before an expensive one.

2 Likes

Hello everyone and I would like to apologize for my previous remarks… they were childish and they came out of a bad day spent trying to get my AP to work and i had another series of failures.

Thank you very much for your kind responses and explanations.

I have attempted to work with the px4 team on this project (using the “convergence” firmware) and had no progress so I wanted to come over to ardupilot due to the excellent flying performance of THIS VTOL.

I was surprised that when i loaded his custom firmware and reloaded his params multiple times (as instructed) that nothing worked correctly at all.

I then tried to use the 3.9 & 4.0 releases and build the params myself to get basic functionality of the servos & motors but nothing works correctly at all.

As a note, I have flown the plane with the px4 “convergence” firmware but I didnt like the performance or lack of control authority… having the aft motor tilt makes a big difference.

is there any way someone could make a test build or something to find out if there is a wrong parameter call in the firmware or ???.. I am simply dumbfounded.

My base params are:
Q enable = 1
Q frame class = 7
Q frame type = 1
Q tiltmask = 11
Q tilt type = 2 (there is a call for a “3” sitting in the description field of another param IE Q TILT MAX)

Im using “41” “motor tilt” for the unique aft motor tilt.

the autopilot (a pixhawk 4) has battery & servo power and the radio is functioning properly. When armed nothing acts right at all… the motors are sort of functioning (ESCs calibrated) but not in the way they should in Q_STABILIZE.
tilt servos dont do anything or even turn on but the elevons sort of work.a

I have poured over the params with no idea of what is wrong.

can anyone help?

thanks

Jeff

I think your SERVOx_FUNCTION needs to be set to 39 and not 41. It’s probably necessary to keep an eye on the Copter documentation as well as Quadplane. See here: http://ardupilot.org/copter/docs/tricopter.html#tricopter

Edit: I just watched the video and it says your friend is using custom firmware. I see what he’s doing and think, yeah! He’ll probably need that customization! I’m not certain that Quadplane can handle that setup out of the box - I may be wrong though. Given what you’re trying to do, I’d recommend learning to read through the source code, difficult as it is at first.

Hi andrew and thanks for the input… It seems that function 39 is for motor 7 in a tiltrotor environment. I have no idea what “41” does but it is in the standard and beta releases. Kris’s firmware calls for function “45” for the aft tilt (not in any firmware description)

the weird thing is nothing works as it should, motors or servos in any flying config (i.e. Q_stab or FBWA).

Can you suggest an IDE that will allow me to explore the source myself in a windows environment? I have had 1 univ level C++ class (80 hours) and Ive tried to learn other object oriented coding (action script) but it is very hard for me to comprehend and get started with it.

thank you very much
Jeff

first thing to do is get every thing working in plane modes then add in the quadplane functionalty from there.

We have a dev wiki:

http://ardupilot.org/dev/index.html

Realflight SITL is a great tool for understanding how all the parameters work. You can run it direct from mission planner. Some example quadplane’s can be found here.

Jeff. I’d say that Kris’s 45 servo function is one of his own code modifications and not in the base firmware. It’s certainly not in the parameter list

As far as reading the code, you could probably install an IDE like Eclipse as described here if you wanted to. I use a Ubuntu VM for all my work and when I browse the source code it’s either just reading it as a text file or viewing the Github repository directly. In either case though, don’t expect it to be an easy task! It’s well worth the struggle though - it’ll open up many more possibilities with Ardupilot if you can master it.

thanks pete… I will set up a plane and verify my test bed is working properly.

BTW, here is a link to kris’s firmware and notes… they have been modding it.

apparently this is a branch of some sort.
It is called “QQ Group:305970641 KRIS firmware” in his instruction manual. They are selling parts to this plane (and other VTOLs) so i would think the firmware would work.

I am working on setting up my IDE to try to dig into the source.

thanks Pete

Jeff

Have you been offered the source code to this firmware?

Peter

Hi Peter,
I have not been offered the source… They have not responded to emails.
A lot of kris’s dropbox repository items (posted above) is in chinese/taiwanese. I have poured through it and translated a lot of it but there is no hint of source code that I can find. I also could not find his branch (listed above).

they just posted a new firmware 2 days ago so they are active. Seems like most of their param files are for quad planes but the one for my needs (called skywalker Y 3x3) seems to be the wrong params.

thanks peter

Jeff

Servers by jDrones