Servers by jDrones

Ardurover won't run from mode switch commands

Hello, Been pulling my hair out the past few days trying to get my rover to run in RTL, Missions, etc. I can run it manually fine. It’s a simple smart car toy type with the typical yellow hobby 6V motors. I’m running a pair of the motors driving the rear wheels and a MG90S servo for the steering. The ESC is a common 20A RC Brush type with a working voltage range of 3.0-9.4V, inexpensive type found on ebay or amazon, etc. Currently using a Pixhawk 2.4.8 running Ardurover V4.0.0. Attaching to Mission Planner 1.3.56 for configuring. Powering the unit with a 2 cell Lypo running through an APM Power Module. From within the Servo Output menu for Position 2 (channel 2) it set for RCIN2 and Position 4 (channel 4) set to RIN4. These settings will allow it to run great in manual mode. If I switch the settings to Throttle and Ground Steering as in the wiki as I assume are needed for running RTL, Missions, etc. When I power up with these setting the ESC acts strange with a continued rapid string of beep, beep, beep, and won’t engage. If I tweak the trim setting and move the throttle stick I can finally get some movement out of the motors. I tried with/without the brake on the ESC toggled back and forth, not much difference. I’ve googled and read tons on the forums and other sources and tried everything I can think of to no avail. What’s odd is that I first had an older APM 2.8 configured and it would run great in manual but when I would try to run missions, rtl, etc. it would duck walk, (zig zag back and forth) trying to reach it’s destination. After hours and hours of trying to solve that I just gave up and decided to go with the Pixhawk which unfortunately hasn’t been any better. Tried a couple different versions of Ardurover with no luck. Here is a link to the ESC type I’m using

https://www.amazon.com/Shaluoman-Brush-Motor-Speed-Controller/dp/B07GSVS8D2/ref=sr_1_3?dchild=1&keywords=20A+ESC+Auto+Brush+Motor+Speed+Controller&qid=1600302062&sr=8-3.

I assume APM is compatible with it as it functioned a little better on the APM 2.8 vs. the Pixhawk. The ESC does power the outputs of the pixhawk, I checked the voltage at around 5.3V so I assume this should be safe.
Please help, it would be much appreciated, I have too much time invested in it to give up :frowning:

Still hoping to get some help on this issue.
I’ve attached parameter and .bin files for ref. and a few pics of the build.
I re-designed a typical skid steer type and turned into a rear drive front steer type. Most of the parts are custom CAD modeled and 3D Printed. I’ll later add an OSD and Pan/Tilt Camera setup. It’s been a fun project up until now. I really want to get the autonomous part working. Using this simple model to understand Ardurover. Later plan to build a much bigger rover. I am more of a mechanical guy and not so good on electronics with a very basic understanding of programming so functions/mapping/etc. is sort of Greek to me. All I can do is keep learning.
I do have an APM 2.8 quadcopter I built a few years back and still fly it once in while, all the flight modes work fine on it. Not sure whey the rover is giving me such headache. – Thanks

Dropbox link to bin file: https://www.dropbox.com/s/dxzsrxr4t8hb339/00000020.BIN?dl=0
Dropbox Rover Photo Link: https://www.dropbox.com/sh/7863l9i0falh68p/AADMMPGWLxPLUC5jqrSnwXHVa?dl=0

Pixhawk Parameters.param (16.1 KB)

Hey guys, finally got it working. Removed the red wire (power from the esc) and supplied power from a BEC to the output rail and bingo all the modes work. I could tell something was strange the way the ESC would rapid beep (only when using the mode switch) like there was a voltage conflict or something going on. I can now capture waypoints, run missions, RTL, etc. I still don’t understand why it would work fine in manual mode using the power from the ESC vs. BEC fed. Hope someone out there can explain, sure threw me for loop.

Servers by jDrones