ArduRover with Optitrack

Hi, I am trying to use optitrack with ArduRover. I followed this tutorial: Optitrack for Non-GPS Navigation — Copter documentation but I was not able to get it to work. I get the following error when I run ‘optitrack start’:

optitrack [Errno 11] Resource temporarily unavailable

I made sure that I can get the optitrack position messages from my laptop using the optitrack client. So I know the network setup is correct. I set my laptop’s IP as the optitrack client IP, and the IP of the computer running optitrack server as the server IP. I also made sure to configure the APM parameters as detailed in the tutorial.

I would really appreciate any help with this :smile:

@itskalvik How have you installed mavproxy?

I suspect this is where the error comes from. When I install on windows there is no issue.

Dose the optitrack set command work?

@Tristan_Redish Thanks for the quick response! And yes, I installed mavproxy following the instruction on the mavproxy website. Also, mavproxy did not throw any errors when I used the set command. I am not sure if that means it worked or not.

@itskalvik so if the set command is working then it seems the issue is not with mavproxy.

Is the UAV connected? How is datastream connected?

I am not an expert with Optitrack but have it configured with 1 uav ( not working 100% yet)


@Tristan_Redish Yes, the laptop is connected to the Pixhawk and I have a separate computer connected to the optitrack system and publishing the position data on a dedicated WiFi network. I also have the laptop connected to the optitrack’s WiFi network and verified that I can get the position data from the laptop using a ROS node. So I figured the issue was with mavproxy…

I wish I could see what is causing the errno 11. Its not part of the Optitrack module so it must be Mavproxy.

Are you seeing messages from you uav in mavproxy?

Can you send a picture of the error ( and what you see on screen)

No I don’t have any messages pop up in QGC and error 11 is the only output I am getting from mavproxy. I did try running it on a windows machine today and it seems to work. So I guess the issue is a Linux specific issue. I will try using a different Linux machine over the weekend and report back :smile:

So with Windows OS when you use “optitrack start” there is no erroe and you get the position data in the log?

like so " EKF2 IMU0 is using external nav data EKF2 IMU0 initial pos NED = 0.1,-0.2,0.0 (m) EKF2 IMU0 ext nav yaw alignment complete"


Yes that is correct :grin: