ArduRover will not use less than 100% throttle in AUTO

I am having a bit of a crisis, and I hope that you guys can help me out.

I am working with an unmanned boat that utilizes a APM 2.6 running ArduRover 3.0.1. The two mechanisms that is controlled through the APM is the throttle and the rudder, both of which are servo controlled (the throttle servo pulls on a throttle valve on a combustion engine).

Until recently everything was working perfectly, but now, all of a sudden, everytime I enter AUTO mode, the throttle servo is set to it’s maximum. The throttle works fine in MANUAL, going from minimum to maximum without any problems.

From my understanding, the two important parameters for the throttle in AUTO is the “Cruise speed” and “Cruise Throttle”, but regardless of these parameters, the throttle is always set to maximum when entering AUTO, and it is kept at maximum throughout the mission.

I have looked at the document “Tuning steering and navigation for a Rover”, where it is stated that I should drive the rover in manual at the desired “cruise speed” and note the throttle percentage, and that this percentage should be used as the “cruise throttle”. However, in my case, the throttle percentage is shown as about 100% both at minimum and maximum, and 0% in when the stick is centered.

Previously the setup has worked as such: When entering the AUTO mode, the throttle could be controlled by the radio transmitter, if this was set to minimum the rover would use the parameters entered in the “cruise throttle” as the throttle input. I know now that the system is design so that the rover is trying to maintain the “cruise speed”, and that the “cruise throttle” is the first guess at what the throttle should be to maintain this speed. This does not work in my case.

Can anyone shed any light as to what can be done in order for the AUTO mode to work the throttle in a correct manner, or if is is possible to override the throttle manually as I have done before. Maybe there are some parameters that I have not thought about.

This problem has also been posted in the ArduRover user group. Sorry for the double post, but I am not sure what topics are best represented in the user group vs here.


I don’t believe you can use 3.0.1 with a APM 2.6.

David R. Boulanger

If you are working with a boat, why are you posting in the ArduRover Forum and not the ArduBoat Forum?

Oh. I actually did not know that there was a dedicated forum for ArduBoat. I think my problem is generic for any ArduRover application, but seeing as it is indeed a boat, it would be more fitting to have it in the ArduBoat forum. Is there anyway you can move my thread to the ArduBoat forum?

I see. I though that it was only ArduPlane and ArduCopter that was no longer supported on APM 2.6. Is it the ArduRover 2.5 versions that are supported on APM 2.6?

I believe Rover 2.5 is the last release for your APM 2.6. I used it on a boat and all was good.

David R. Boulanger

The Rover 2.5 worked very well. Thanks for your help :slight_smile: