ArduRover stops randomly in middle of mission with 32 waypoints

I am testing ArduRover (firmware 4.1.0 with mission planner 1.3.75) with a skid steer rover using the holybro pix32 V5 with pixhawk 4 gps module and am running into an issue

Midway thru the mission the rover randomly stops.

I tried reviewing the logs but could not figure out the issue. I do not understand how to parse the logs or plot the appropriate events - so some pointers on that would be useful. Running log AutoAnalysis using the missionplanner log utility indicates an issue with the Compass but not sure if that is causing the abort

On the first run I noticed FS_ACTION was set to 2 so I also tried with FS_ACTION set to 0 but still the same issue (though the run with FS_ACTION set to 0 completed more waypoints)

log with FS_ACTION=2
https://drive.google.com/file/d/1t3sAONLuI4et_X0Bf6ObNpDaCpTt6bdH/view?usp=sharing

log with FS_ACTION=0
https://drive.google.com/file/d/1R3txv2hjWMKkmW1pMzW9NEUJjX6qQYpJ/view?usp=sharing

Could someone please help me diagnose the issue or point me to some links to help me decipher the logs better.

Also is there any documentation that lists events that would abort the automode (is there anything besides FS events??)

Thanks!
Vir

I’m not sure if this covers the events you are talking about but you have Arm/Disarm commanded action in the log from your Chan6 switch.

Hi Dave,

Yes - I was using the arm disarm switch so that the logging started only after arming. In the first log (with the FS_ACTION=2) the first arm event is when I started the mission, the rover then stopped roughly before the first waypoint, so I hit disarm and then armed again at which point it resumed but stopped again in a short time before even making it to the 2nd waypoint.

In the other log I did not disarm again (the rover did make it past a few waypoints in that instance though).

I did have a question though - What values did you pick to plot?? I could not figure this out.

OK, wasn’t sure if it was intentional. I selected GPS>Spd and RCIN>C6 in that graph. I don’t see anything in the log to determine why it stopped. What’s the Mission Plan look like if you want to share it?

BTW-Don’t bother with Auto Analysis, it’s not up to date.

Note: You should have battery logging, it can be useful.

Thanks Dave, I will try that (still very new at this so please excuse the newbie questions)

I think I have enabled all logs (except for IMU raw) I will doublecheck

Here’s the complete mission plan…

https://drive.google.com/file/d/1j5bvEBcGLW8HPM3QV-v8sR2VmFhTiiuW/view?usp=sharing

Hi @Vir_Shroff,

It looks like some kind of frame issue (not software) that is the cause.

The picture above is (I think) the period where the vehicle has stopped. We can see the desired speed (in red) remains high and the output to the motor (in blue) goes to 100%. Despite this the vehicle’s actual speed (in green) drops to zero.

I’m not sure the exact cause but it seems like a mechanical issue perhaps. Maybe when the steering is fully left or right the vehicle cannot move forward even if the throttle output goes to maximum? Just a guess.

1 Like

@rmackay9 I will investigate this further - I did not do any steering tuning maybe that has something to do with this issue? Will read up on this - I am guessing I will need to somehow setup a bluetooth link so I can collect some telemetry data and tune the steering controller. Will work on that… Thanks!

Along those lines some skid steer vehicles with insufficient torque will stall out from tire scrub on some surfaces. Looks like you are on a road surface?

@dkemxr yes on a road surface… I will work on getting a bluetooth module hooked up - maybe that telemetry data will help with some additional info

I would use an ESP8266 radio rather that a BT module. Cheap and more robust connection. About the same range (short) perhaps a bit more. I have them on most models including the Rover.

I had a HC06 Bluetooth module handy so used that for now - but will switch to an ESP module (have ordered one…)

I noticed that when I enable battery voltage on the hud I am seeing this

I guess I need to figure out how to configure the battery monitor first :frowning: