Servers by jDrones

ArduRover + QGroundControl + Joystick cam

Hi folks,

I am setting up rover robot with ArduRover and Pixhawk radiolink (running ArduRover 4.0) - remote control over ethernet cable (so no RC radio). Everything works fine except the gimbal control.

I have managed to make the gimbal’s “stabilize” feature get to work (so the servos are connected properly). But I can’t control the camera bimgail with joystick :confused:

I belive my camera setup should be properly configure, but I am not sure I selected “default mode” properly… BUT I tried all of them, so that should not be the problem

Joystick is standard F310 joystick
Screenshot from 2020-05-22 17-26-31
I tried to configure Gimbal Up/Down/Left/Right but when I press these buttons there is no reaction :confused:


I also tried the “Enable gimal control” but it did not changed anything

Is there something I am missing in making this work?

Thanks for any reply
John

You’ll likely have to ask how to get this setup in an ArduPilot firmware forum. The joystick code sends a DO_MOUNT_CONTROL to adjust the gimbal angle. Which I believe ArduPilot does support. So I believe this should work.

Servers by jDrones