Ardurover on Kakute F4 v2 Telemetrie problems (Solved)


I’m setting up a rover project with a kakute F4 V2, but I cannot get Telemetrie 1 to connect.

I’ve looked at the documentation of the latest firmware of the Kakute F4, and cannot really find good information about the pinout of the board.

I got the latest rover firmware loaded on the board.
The GPS is working and connected to pins R4 and T4
The RX Reciever is connected to R3

For telemetry I wanted to use an ESP8266 but could not get that to work, so got a 3DR v2 Sik now.
It’s connected to pins R6 and T6…

When I power the 3Dr air unit seperatly (so no connections to RX and TX) the unit connects to the groundunit.
When I connect R6 to TX on the air unit and T6 to RX on the airunit… the 3DR does not want to connect to the ground unit anymore (blinking blue light) and the red light is flashing indicating there is some serial cummunication flowing there.

I somehow have the feeling that I dont understand the pinouts of the Kakute F4’.
Can anyone confirm that pins R6 and T6 supposed the be Telemetry 1? and if this is supposed to be uart 6 or is it remapped to uart 1?

That’s correct. UART6 on the Kakute F4 is mapped to SERIAL1 in the Ardupilot parameters.

Have you checked the power and ground pins for the 3DR radio? Is it the 433MHz or 915MHz radios

1 Like

It’s the 433MHz version (500mW).

When I power the 3DR by only using the power and ground pin the ground and air unit connect with each other (solid blue light, or is it green cannot remember :smiley: )
But as soon as I also connect the RX and TX to the flight controller the air unit powers up but the blue light keeps blinking, same for the ground unit.
Feels like it get’s confused when connected :smiley:

hmm … could be RF interference over the tx/rx lines. Have the radio modules worked with other flight controllers? Do you have a 915MHz radio module pair that you could use instead?

1 Like

No I just recieved them, they are new.
I am a bit suspisious as I thought they where originals, but it seems like a chinese copy judging by the absence of a micro usb port on the air unit.
I can only read the settings with an ftdi cable.

The problem is I don’t really know where to look first.
I tried connecting tele1 to an esp2866, but could not get that to work also… not knowing if it’s the esp8266 or the flightcontroller I thought switching to the 3DR would at least eliminate one factor.

Can you connect the FTDI cable to the RX/TX (plus ground) on the Kakute? you can then verify if the Kakaute’s telemetry is working.

yes I can connect an FTDI cable to the Kakute.
How can I check then if the telemetry is working? Never done that before :slight_smile:

You can use any Ground Control Station software (such as Mission Planner). Same as if you’re connecting via the radios.


Thanx, I will give that a try.
i also contacted the store about the 3DR, seems I ordered the wrong one. it is an original but this one the air unit has no option to connect to a pc with usb and you need an ftdi cable to get into it if they did not pair.
I’m changing them for a set where I can “read” both the ground and air unit with usb.
That will probably not fix the problem… I will first try to connect to the flightcontroller through the telemetry port.

@stephendade I think I found the problem.
I tried connecting to uart 6 directly with an ftdi cable and could not get it to connect.
The probem was that I had the ground connected to a ground on the pdb and not on the flightcontroller.
Moving the ground wire to the flightcontroller fixed the problem.
So I know now that uart6 is serial 1 and works as telemetrie 1.

Thanx again.


You’ll want to connect those two grounds together, otherwise you’ll have other issues with the setup.

The ground of the pdb was connected to a ground on the flightcontroller, but that did not seem like enough.

1 Like