ArduRover ESC Help


I am having an issue with the ESC not powering the motor. I do not believe the issue is on the mission planner side of it. I think it is a calibration issue with the esc but I do not have a real idea.

It is a Dynamite 60A Brushed ESC, the 5v on the BEC is removed and the signal and ground are plugged into Serial 3 of my SpeedyBee F405Wing Board. The esc is pinned for F/R (No braking).

Mission Planner sees the throttle change in the Servo Output Tab, PWM Freq set to 1 KHz based on what I saw from other 1/10 scale rc esc’s, Set to Brushed Bi-Polar on the pitch stick (Some people might not like this but it shouldn’t effect the esc working or not)

When powered, the esc beeps twice to indicate Li-Po but does not long beep to indicate ready. The lights continue to blink which makes me think it is a calibration issue since the light should be off in stop (neutral) position.

The image below is some information from the manual. I have tried to follow their calibration instructions but have not gotten anywhere. Maybe the esc isn’t seeing any pwm signal from the FC? Can I test this?

I am also not opposed to just getting another cheap 1/10 scale brushed esc if some esc’s just don’t work well with ardurover.

Thank You

I also suspect that the esc isn’t seeing a pwm signal. Have you confirmed that the throttle is armed? pwm signal might not be generated by ardurover if throttle not armed. You might also want to test with another pwm signal source such as a regular RC receiver or a servo tester.

I have turned off the prearm checks and mission planner says it is armed. The steering servo works fine. I do not have another rc receiver or a servo tester but maybe I should look into getting one.

Try plugging another servo in place of the ESC; if you observe that servo moving about as you adjust throttle (and as you see the output channel pwm values change in missionplanner) then you know the f405 is outputting pwm signal on that channel.


Use MissionPlanner motor test to verify operation.

Thank you. I forgot to mention this but I could not get it to spin using the motor test function. It did not pop up any errors with the arming check off.

Thank you for the suggestion! I plugged the esc into my serial 1 (Steering) and the motor worked great! Soooooo, now where do I go from here? I feel like there is a simple solution here that I am missing.

look at the rc channel outputs in Mission planner (Data tab, status tab, ch1out, ch2out, etc.) to be sure that ardupilot thinks its generating outputs on the channel you have connected to your esc. If not, then you have a ardurover config problem (I still suspect arming)… But also check Mission Planner/Setup/Servo Output to ensure the servos are mapped to the correct outputs. (For me I use ThrottleRight and ThrottleLeft).

I do not think it is an arming issue because I turned off the prearm check and it seems to arm just fine.
Screenshot 2023-10-21 134234
I have checked and double checked my outputs and servo mapping, all should be good. I have moved throttle over to signal pin 4 since the original post.

I just think it is odd the esc works flawlessly on the steering ouput. Why are the two ports different? Is my esc frequency wrong? I can’t go any lower though to match that of a servo.
When I plug my servo into the throttle output, it goes to a certain position every time which makes me think there is a pwm signal coming out of the signal 4 pin.

did you check mission planner/data/status tab/ch4out?

Sorry I ignored this suggestion earlier. I just looked at the status tab (Which I never knew existed and it has so much useful information) and it looks like it is outputting the correct pwm value, but still nothing from the motor. Interesting discovery I made earlier though, it works fine in regular mode (1500-2000) pwm. But when I put it into Brushed BiPolar, the esc never long beeps showing that it is ready, even though it is outputting a pwm of 1500 just like regular mode does. Thank you for your patience with me.

why are you setting it to brushed bi polar? its a reguar ESC you shouldnt change it at all. brushed bipolar setting is for H bridge motor drivers not RC speed controllers, I assume you havent read any documentation on what the motor settings actually do?

literally the first paragraph of the motor setup page

Brushed motor ESCs that support RC PWM input (PWM signals that are 1ms to 2ms in width) are the easiest to use because no special configuration is required and the rest of this document can be ignored. Most hobby grade RC Car ESCs are of this type

I was going off of this part where the only mention of using reverse on the same stick is Brushed Bi-Polar.

“Normal” is the most common and involves sending PWM values normally between 1000 and 2000 (1ms ~ 2ms)*
Brushed With Relay” is for brushed motor drivers that use a relay pin to indicate whether it should rotate forward or backward.*
“Brushed BiPolar” is for brushed motor drivers that, a bit like “Normal” PWM. These devices interpret a low PWM value for reverse, a high PWM value for forward.

But thank you for informing me that it is for H Bridge motor controllers. I will use Normal