Ardurover dont stop at wayspoint in auto mode

Hi all,
I installed pixhawk into my auto. I set up ardurover (throttle, speed…)
I written some waypoints into my aurdurover, and switched my transmitter to AUTO mode. Then my car start to WP1 and WP2 and WP3 (end point of route) and stopped there and monitor show me hold. After i switched my transmitter to RTL and car came back and stopped at start point and monitor show me hold.
I would like to stop at WP1 and WP2 too for 10secounds.
What command i use and how can i set this into mission planner?
Thank you.

During a mission when a Rover reaches a waypoint if Param1 of that waypoint is set to a value greater then 0 then the rover will wait at that waypoint for that number of seconds until moving on to the next waypoint in the mission. See here:
Thanks, Grant.

Thank you gmorph!
I tried this way but my car didnt stop at waypoint, only at the end of mission or at home when I swithed my transmitter to RTL.
Any other idea?
Can you help me what command must use from all of them for any waypoint where i want stop my car?
I tried to found any options for this into basic tuning, standard param, param tree… but i think there are good settings because can stop my car at the end of the missions, and at home position when came back (RTL).
So i think i didnt set good the commands (i m not sure that i used good commands) at waypoint.
So as you tell me: I i just must put any waypoint into mission planner, and set 10 in param1 if i want stop my car for 10secounds and after will start to the secound WP?
Which command must use for this WP?
Thank you one more time.

And i have an other question.
I want connect one power servo (6V 33kg torq) for steering my car.
I connectect into aileron port in pixhawk, and i connected ground and power from bec (jumpper set 6V) and sign from the pixhawk, but when i tried to steering wheels the servo started turning fast left and right like got something noise from somewhere, and i cant controlling servo in manual mode.
I unplugged and i connected this high torq (6V 33kg) servo into the pixhawk directly and the servo work normaly without any shakes, but was slow and weak unpowered.
Please help me how possible connect this high torq servo into my pixhawk.
I tried to set that value into mission planner to waypoit, but doesnt work. :frowning:
Thank you very your patient and supports.

Does the ground not need to go to the Pixhawk also? Not sure what you are saying.

David R. Boulanger

Dear David,
Pixhawk get 5V power from one BEC and works fine.
I just want to connect one powerfull (33kg torq 6V 130g) servo but pixhawk can give 5V on servo out connectors.
How can i connect this higher voltage operation servo into pixhawk?
As i told i tried to connecting this servo into pixhawk so:
Power: ground and + from another BEC (jumper 6V) and Sign: to aileron port of pixhawk. Worked enough operated well powerfull but when i started mooving the servo that started shaking fast right and left (seemed something noise mooved)
I connected directly to aileron port of pixhawk (power, ground and sign from pixhawk) no shakes but servo is slow and weak on this bacause pixhawk have 5V power on this port.
Thank you

Dear gmorph,
Thank you.
I made one path with 3 waypoints.
I set the first waypoit as you told me, i put 100 into WP1 in the first cell. But the rover didnt stopped. :frowning:
But rover can stop automatically (i mean i think the thr, and speed setups are in good values) at the last WP, and when i switch my transmitter to RTL the rover come back home and stop there.
Why didnt stop my rover at the WP1 if i set value into there?

I power my servo rail on my Pixhawks with a BEC set to 5.7 volts. I think you can power the rail with 6 volts but then using the servo rail as a back up power supply for the Pixhawk may be a problem. I think the rail can handle up to 7 volts but you would need to check the Wiki about this.

David R. Boulanger

Yes, if you put 10 in param1 it should stop for 10 seconds at that waypoint.
Can you please send me your log file and I’ll have a look.

For your servo I think you would need to plug the ground into the “aileron” port on the pixhawk as well as the signal wire.
Let us know how you go.

Thanks, Grant.

I sent you a private message.

Here are my config, parameter, mission plan…

If anymore can help me, please.

Thank you


I still have this problem.
Anybody have any idea for?
There are my log, plan, parameter list…

I had a look at this log file
2016-04-09 17-18-51.tlog
You have 4 mission items in it. 2 waypoints, a do_repeat_servo and another nav_waypoint. NONE of the nav_waypoints have parameter 1 set to any value other then 0 so the Rover won’t wait at any of them.
Thanks, Grant.

Thank you.
I created new trip in mission planner and i uploaded into a new folder.
Still dont stops at wp.
PLease help me gmorph.

Hi Gergo. I extracted your mission from the tlog you sent. It has 2 waypoints with a pause of 10 seconds at each waypoint. When I run the mission in the simulator it works perfectly fine for me. Are you sure you uploaded that mission to your Rover? A dataflash log (.bin) would tell us if you had.
What version of APMRover are you using? This feature is only available in 3.0.0.
Looks like a nice part of Hungary your in.
Thanks, Grant.

I checked (ArduRover 3.0.0 (2c4aaf7c)
Yes i written this mission into my rover, but didnt stopped at first wp (the status didnt change AUTO to HOLD on flight data screen when rover arrived. Rover stopped only when finished mission (last wp) and was HOLD on the flight data screen, and when i switched to RTL on my transmitter and and rover arrived to home, and changed AUTO text to HOLD in both situation.
Thank you.
I looking forward for the nex help. Thank you your patientfull helps.

It won’t change from AUTO to HOLD when it pauses at the waypoint. The Rover is still in AUTO mode - its automatically pausing and then driving again. It only goes into HOLD when the mission is over.
Can you attach a link to a dataflash log (.bin file) when the rover was driving and didn’t stop at the waypoints and I’ll have a look.
Thanks, Grant.

I uploaded and px4fw.bin into the same folder.
I hope this is that dataflash log file what you want and need to checking.
If you need any more just tell me and i upload that soon as i can.
Thank you my friend!

Hi Gergo. I’ve had a look at your parameters from the dataflash file 217.BIN and there are quite a few problems.
SPEED_TURN_GAIN - you have it set to 0 - default is 100. Basically your saying turn the throttle off when the rover is SPEED_TURN_DIST (3 meters in your parameters) away from the waypoint. That’s odd.
SPEED2THR_P - you have 200. The range is 0-3 with the default being 0.7.
AHRS_EKF_TYPE - you have 1. Better to set it to 2 so it uses the new EKF2
ARMING_REQUIRE - you have 0. This means you can run the rover without passing the arming checks. Those checks are there for a reason and will let you know if you Rover has a problem.
AUTO_TRIGGER_PIN - you have 1. That value is only valid on an APM but you have a Pixhawk compatible board. Are you really using this functionality? If not set it back to -1.
BRAKING_PERCENT - you have 100. So you want to apply full brakes when cornering? Does your ESC support braking? I suggest you set this back to the default of 0
CRUISE_THROTTLE - you have 5. So this says it takes 5% throttle to move the rover at the CRUISE_SPEED you have set which is 1.5m/s. Its possible but would indicate your rover is quite fast. Perhaps try upping it a bit more.
FS_THR_VALUE - you have 200. But setting this it says that when the receiver loses connection with the transmitter it will output a value less then 200 on your throttle channel (3 in your case). Is that correct? Normally users set this to just below THR_MIN for the throttle channel.

I also looked at the mission in the log file and it looks correct.
Please correct the parameters above and try again and let us know. If it fails again attach the dataflash log please. Only the 1 log where the issue occurred.

Thanks, Grant.

1 Like