Ardurover 3.4.0 Boat Frame Prearm badGPSposition

Hello everyone and thank you in advance for any assistance.
Decided go from the sky to the seas and i am looking at my first issue.
Building a Rover Boat and testing the electronics on a plywood rig. Radiolink MiniPix (as a test board) with an M8N GPS and ardurover 3.4.0. Fresh flash and all calibrations done. I have for now manual, steering, hold and RTL.
I can arm on manual with a 3d FIX of 12sats and hdop of 0,7-0,8 but if i try any other mode i get Prearm badGPSposition.
As i said its all dont on a test rig outside so i have proper 3D fix and i can move the rig around by 8-10m so i can test all modes before i start swimming to fish it out.
Can anyone help with this issue?
I just edited this post and added a small log that i just run which cause the same issue. hdop is a bit higher on this but still sats are 10-12 and i was getting badGPSposition
00000005.BIN (263 KB)


I think it’s just a matter of going outside. beyond the number of satellites and hdop, the EKF has to be happy with the position so it can take a while even if the GPS appears OK.

Hello and thank you for your reply.
I am outside running the tests for about 36hours now. i even let the whole system on for 20+ minutes and tried to see on steering mode if i can arm, but i still get bad position.
I have to admit that this radiolink unit, still uses its own MP and even though it said loading FW 3.4.0 now that i tested on my regular PC and MP that i use for multi and Fixed wings i saw that FW was 3.2.3 and not 3.4.0
checked 2 GPS units, also checked then with u-center that cfg is ok and even tried to load multirotor FW on which everything worked fine.
Maybe my issue is the 3.2.3FW?

and as i was typing the reply it seems i started getting closer to the root.
a) set AHRS_EKF_USE to zero, this took my bad AHRS message out.
b) programmed again the GPS with baudrate to 38400 and to 5Hz
d)GPS_TYPE to 1

After that i am able to ARM on STEERING and get message that SMARTRTL is not possible.
Armed the rig and set throttle to 50% on steering mode, took it 10meters away and switched of the radio. It shows RTL on the screen but not SMARTRTL.
Now i might take it to the SEA, since there are no ponds around here.

Ok, seems very strange. From the little I’ve heard, the radiolink people have created their own version of ArduPilot with some changes on it that they’re not willing to share (an apparent license violation). So I’m not sure if the main stream ArduPilot runs on these boards.

Good Morning,

I realized as much and i was told that recently they shared info.
Seems its time to trash this board for now until its fully functional with proper support and test direct on my good boards.
Thank you for your help.

1 Like