Arduplane v3.7.1? If EKF_ENABLE = 1, EK2_ENABLE = 0, and AHRS_EKF_TYPE = 2, whats running inside?

See pic below, in 3.7.1 there is a msg that rangefinder is engaged, but not in 3.8. And landing accuracy is not stable, sometimes good, sometimes bad.

@pompecukor How do your plane land? With a parachute? My plane lands with a hard touchdown.

Depends on what the customer orders :slight_smile:
Anyway this one can do both. Parachute for tight area and auto-landing for normal.
How did you get that message to display. Learn something new everyday with mission planner

As I said it is working for me. 3.8 beta 5

Oh yes it was working for your plane! Good plane for you!
Could you share your parameters about rangefinder? Or all parameter for the best:wink:! When you review a log file in Mission Planner, you could filter with keyword MSG to get the msg list.

ok, lets switch over to email

OK,thanks! …

Which rangefinder do you have pompecukor ? Is it accurate ?

So, this solution does not seems to help us. We have tried without luck, we can’t keep getting AHRS health error unless we set the EKF params back to what they were before. And it is weird that now two Pixahwks are having this problem. Guru, I’m waiting to hear from you. What could be the issues? Only a couple of months ago we did not have this issue. Thanks in advance.

I dont think AHRS problem is caused by changing EKF parameters, you can post some pictures of your issues, or logs, to share the detail. I have several Pixhawks working well here and planes flying well too.

Thanks for your response.
I will get the logs and post them here, they are in another PC that I not have access now. But I thought the AHRS was related to changes because when I changed back to original settings, the error went away, and that is not once but several times that I tried.

EKF_ENABLE = 1, EK2_ENABLE = 0, AHRS_EKF_TYPE = 2, are you the same?

Thanks again. yes I put exactly that. In fact I found the that AHRS_EKF_TYPE = 2 was already set that way, so I only changed EKF_ENABLE to 1 and EK2_ENABLE to 0 and wrote. There was no joy!

You are using arduplane firmware, right? You can try to re-calibrate the accelerometer sensors. Or post more information here.

Yes, arduplane. Thanks for the advise, will try that. The only info available to post will be the log. Only that, it is weird two Pixhawks back to back behaving exactly the same way.

Yes understand! But here I get several pixhawks working well too. So, maybe there are some other parameters you are different from mine.

Good point, may be I should email you my param file to check it.

All, reading through this thread, sounds like we are having similar issues on 3.7.1. We haven’t upgraded to 3.8 yet, as we were waiting for time to test it before using it on active aircraft. However, it is looking like EKF in 3.7 is an issue? I can try to disable, but I am curious if it has been confirmed that these issues were resolved in 3.8 stable?


Altitude drift problem? We have test 3.8 stable for several flights, problem seems not been solved! And wired that Maxbotic ultrasonic rangefinder doesnot work well in 3.8!

I’m a newbie so dont shoot me please!!

IMPORTANT: Do not set AHRS_EKF_USE = 1 unless you have performed an Accel and compass calibration. Failure to do so may result in an erratic flight path due to bad sensor data.”_

In MP it’s set by default to 1

Could this be the/a problem? Does the above mean first set AHRS_EKF_USE to 0 do the Accel and Compass calibration and than set AHRS_EKF_USE 1 again?