Arduplane - pitches down when switching to FBWB and Auto flight modes

I am having problem trying to get a Bixler 2 using Matek f405wing FC that pitches down when it is switched to either FBWB or Auto modes.

The plane flies well in manual and FBWA modes, the CoG looks good and is checked prior to every flight.

I have followed the setup process for the TECS with no change in the behaviour.

I have attached the log file from the latest flight as it clearly shows the plane losing height quite quickly and steadily once switched to FBWB. The mode needs to be switched back to manual quite quickly to avoid a crash.

Looking at the log I can see that elevator servo putting the plane into downward pitch as soon as I switch to FBWB but I am unable to determine why it does this.

I would appreciate any guidance or help that anyone can provide on this topic.

Many thanks in advance.

https://drive.google.com/file/d/11B1qQCpjRVYVwhVnFZB0q-jK-kyOrUyU/view?usp=sharingJuly 3rd log file

Haven’t looked at your logs, but have you checked your TRIM_THROTTLE and TRIM_PITCH_CD settings?

This might also be useful: Tuning Cruise Configuration — Plane documentation

Chris, many thanks for your suggestion and the link.

Brian.

The file is missing.
I can recommend you to use SERVO_AUTO_TRIM.
Send on-board logs for further investigation.

Please see the attached log link. I think I have SERVO_AUTO_TRIM enabled but I will check again

https://drive.google.com/file/d/1-swECtu86rMxvdt38ve-isDB02QA0UWR/view?usp=sharing