ArduPlane HIL using XPlane

Hi everyone,

As part of our project to get a fully autonomous plane working with the APM 2.6 we decided to use HIL simulation with Xplane. We followed the instructions shown in the link below to get Mission Planner and X-plane “talking” to each other, however since those instructions were written it seems the HIL firmware download doesn’t work anymore and you have to set HIL_Mode = 1 in the APM parameters (I know I’m probably telling you what you already know). … imulation/

When we try to get the HIL working by setting the mode to 1, the APM doesn’t seem to pick up any sensor data and the simulated plane doesn’t react to our Radio Controller, although we can get servo output waveforms in the Mission Planner simulation tab.

tl;dr How do we get Mission Planner and X-Plane simulation working now? It used to work when we could just download the HIL Arduplane firmware but with this new HIL mode parameter it doesn’t seem to work and the APM won’t react to MAV commands so we have to reflash it.

Any help or advice would be much appreciated

Same problem here, had you been able to work this around already? I’m getting good data from the sim (GPS coordinates, Aircraft attitude and heading, etc.), but can’t send any data into XPlane. Not even to the APM (on Radio Calibration it doesn’t seems to be receiving any data from the RC). Please let me knoe if you had already find a solution.

Problem occures when we try to simulate the senery working with pixhack using HIL simulation with X-Plane. It is amazing that we have the same data both in the simulation Page and the X-Plane interface. However the data in the FlightData(Mission Planner interface) cant update when we try to change the pose of the plane in X-Plane.

Does anyone has met problems like this? I don’t know how to solve this problem, may somebody can give hand, Thank you very much.

I have been having the same problems. Although when I set HIL_MODE=1 I get a BAD AHRS message and cant arm. If i set arming_require=0 and try to calibrate the gyro is all over the place.

Did anyone get this working? I looks like there is not a HIL_MODE = 1 param anymore. I am using Ubuntu to run xplane and mp using mono.

HIL is no longer supported, you can use XPlane with SITL tho.

Thanks for the quick reply! Darn that’s a shame. I have been using the SITL its great I would like to be able to have my companion computer do data collection while in the sim environment though.


You can totally still do this, you just need to specify the comport when you run sim vehicle. i’m not 100% sure of the command, maybe @peterbarker can advise.

Yea I am thinking it would have to be a UDP connection. I have xplane and running on a laptop. I would this to have data collected on an RPI.

I did find this in the parameters list. Looks like there is still a HIL mode option. However after rebooting it just says waiting for first HIL_STATE message. I see this message is depreciated in the message list.

This is with the latest QGC v3.5.6 and arduplane 4.x.x