ArduPlane 4.1.0dev (VTOL QuadPlane 4+1) - Fence and Safety not supported

I have tried several builds of QGC on Mac, Windows and Android. I was just after setting up a basic simple cylinder-style fence of 400m radius and 150m height as well as configure the battery levels.

However the SAFETY section shows as “not supported” - this doesnt appear: https://docs.qgroundcontrol.com/master/en/SetupView/safety_ardupilot.html#plane

My next question is how to setup a FENCE, as the FENCE section in the Plan is grayed out.

You probably need to update to the latest daily build of QGC

Not sure if this means anything, but i had to set the param “Q_MAV_TYPE” to “VTOL_QUADROTOR” (Default was “AUTO”), else QGC detected it as an ArduPilot Fixed Wing.

With it set to AUTO, I can see the SAFETY section, but the Fence is still grayed out. With it set to VTOL, both are unsupported.

I will try the latest daily build tomorrow and report back.

And how old is your ArduPlane 4.1.0-dev ?

1 Like

I am unsure how to check the age of the ArduPlane 4.1.0dev, the craft was pre-assembled for me (I got it last week) and they basically say just use Mission Planner. Does this code mean anything thing, it pops up in MissionPlanner next to the firmware version: 211cd525 (does this HASH related to a github commit? https://github.com/ArduPilot/ardupilot/commit/211cd5255da771db78bb22578c9daede40d227f2 )

I now have QGC Daily Build 13 June 2021 (downloaded this morning from the links). And it allows me to plan a mission as a VTOL but the Fence and Safety are still not supported.’’

Screenshots included below are without the craft connected to trace down a question about VTOL_TAKEOFF and Transition Direction. One thing that is acting weird on the planning is the VTOL_TAKEOFF does not allow me to move the T (Transition) point in the waypoint.

Compared to PX4 Pro VTOL

Also, here are similar missions planned using PX4Pro VTOL and ArduPlane VTOL. The PX4 shows a VTOL climb to height, then fly at that level. The ArduPilot is a small climb then a plane climb to height, and missing the T waypoint?

I ran a test of this QGC daily build with the quadplane. I made a VTOL take-off, 3 waypoints and a VTOL land.

When the mission started, it started the front motor only and attempted to execute the VTOL takeoff as a plane.

After testing on Mission Planner, I conclude the issue is likely, as mentioned above, an out of date firmware.

Yes, that FW version is ancient. Please update to ArduPlane 4.1.0-beta4 and re-test.
The “fence support in QGroundControl” pull request got merged after the version you are using.

1 Like

hi twobit, Were you able to solve the issue, Im using the latest Ardupilot firmware and QGC, still I have the same issue as yours, cant set the transition direction and no safety options, What am I doing wrong,
I flashed the pixhawk in mission planner, do I have to do it in QGC?

Hi,

I have not been back to review this yet. I am about to complete a new build (a test quad plane) and it has arduplane 4.1.2, I hope to test it next week with manual flights and if goes well a mission.

Twobit

1 Like

nice to hear that, please update here once you do,

HI, could you please post the commit id, and date of the “fence support in QGroundControl”?

I did some tests yesterday night with ArduPlane 4.1.3 running in SITL and QGC.
The last official QGC 4.1.4 was able to upload and download of rally points, fences did not work, I then compiled the branch “master” ( a6da4e5802905fc408ab0b3a92bf15e12d14a1b7 from 16.11.2021) where a new version of the mavlink subsystem is included. Then:

  1. Up and download of rally points worked, and they are used by the ardupilot.
  2. Up and download of a circular geofence worked. To tell the autopilot to use that fence you have to set the parameters starting with “FENCE_” in the Parameters page of QGC. Finally ArduPlane used that fence on breaching it, and returned to the rally point, but not to the dedicated “B” breach return point. (The return point assigned to the fence)

What did not work:
3. Safety Page: It is still disabled. I can somehow understand that because the FENCE parameters a bit complex designed on ardupilot side.
4. Using of breach return point for circular fences. Neither it worked in Mission Planner 1.3.75, or it was my fault, and needs special set up. The vehicle always returned to the Rally point.
5. As described by @twobit above, the height profile in the Terrain View, looks wrong in the part of VTOL take off . But ardupilot SITL flew it correctly (I have checked only the take off).

Finally my hint: It seems to be a good idea to first test in in the SITL simulator before flying in the field.

Can you make sure to write up the problems you are finding in a GitHub Issue?