Arduplane 4.0.9 dives in Auto modes

I have two large mapping frames that have Black Cubes in them. They both were running 3.9 firmware and flying well. I completely erased both and installed the Rover firmware to get rid of 3.9 and installed Plane 4.0.9 as a new install. Both of these planes have flown several hours without a problem with the previous firmware. These planes are big and I need both hands to launch so I use Auto Takeoff with a short loop in Auto mode before taking control. After setup and calibration, I flew both of these planes to tune and on take off, both planes climb to 100 feet and start to dive. I can put both planes in FBWA and they fly level at half throttle. I have tried to recalibrate level with no luck.


A third plane that was changed over to 4.0.9 at the same time is running an older Blue Cube. This plane doesn’t have the same issue.

Hi Michael,

I have only looked at the second logfile:
Please check your waypoint datas.
waypoints
Parameter 7 of nearly all waypoints is consistently 30.48 meters. During automatic takeoff the aircraft reaches about 60 meters altitude, consequently the aircraft sinks with activation of next waypoint following CMD_NAV_TAKEOFF. Its also noticeable that parameter 7 of TAKEOFF “waypoint” is only 3 meters (if it is not an error of the data-extraction by mission planner).

Rolf

Thanks for looking. I will check. It is supposed to be takeoff to 100 feet and all subsequent waypoints are supposed to be 100 feet. It still shouldn’t be diving to 60 feet with a 30 meter waypoint.

Again, altitude in feet. Not meters

Whether we use feet, meters or ångström, the ratio remains the same :wink:
30,48 meters = 100 feet


The overshoot during altitude regulation could be due to poorly adapted TECS parameters.
Are you sure you want the aircraft to fly towards the first waypoint after reaching 9.5 feet altitude ?

It is aimed at the first waypoint when armed and hand launched in the same direction. That should not matter. The question is why is it reaching 100 feet at the first waypoint and steadily descending to a very scary altitude. The lowest I let it go is 60 feet. My other plane runs fine on the same plan.

OK, I have connected to Mission Planner and with the tuning box open, in FWBA mode it it showing a desired pitch down when plane is level. I can perform an Accel Cal. and the actual pitch and the desired pitch lines are on 0. If i then go to setup and calibrate level, again it is showing desired pitch is down when plane is level. Then after changing modes, it goes back to -2 degrees desired pitch.

-2 deg pitch down at throttle idle is default, see https://ardupilot.org/plane/docs/parameters.html#stab-pitch-down-low-throttle-pitch-down-trim for reference.
as @Rolf said, there’s something funky in your waypoint files. check the requested altitudes:

your plane is just doing what it’s told, and, btw it’s tracking really well. see actual alt vs height demand:

better try to ananlyze and understand what the issue is before deliberately changing unrelated parameters.

In Auto mode, the plane reaches 100 feet altitude per waypoint 2. The plane then falls down to 60 feet instead of maintaining 100 feet that is requested in waypoint 2. While still in Auto mode, I pull back on the elevator to regain altitude.


I do not understand why it flies level in FBWA, gaining slightly when above half throttle, and pitch down in Auto mode. The height in the takeoff is not a problem and never has been. I have used this same flight plan for a couple years now launching planes that are too big to launch with one hand. The altitude is exactly what I put in, it just isn’t maintaining it in Auto or Cruise. Also in Manual mode, the plane needed several clicks down elevator to keep it from nosing up. I don’t think that has anything to do with it, though.

I think the sinking is due to incorrectly set speed parameter TRIM_ARSPD_CM,1200. You have activated the airspeed sensor ( ARSPD_USE,1 ), so the controller tries to reach the speed set in TRIM_ARSPD_CM = 1200 cm/s !!!.
This is below the stall speed and below ARSPD_FBW_MIN,16.
As soon as the first waypoint is approached, the controller will therefore take back throttle so that the aircraft must sink.



I would set TRIM_ARSPD_CM to the desired cruising speed (cm/s) and TRIM_THROTTLE to the throttle setting needed for that (0-100%)

Rolf

@Rolf i don’t think it’s tecs tuning. i‘d expect throttle trying to compensate and, if not successful, hdem to diverge if the requested alt can‘t be achieved. that‘s not the case. imho the plane is following the demanded height quite well.

simple test: fly in CRUISE mode, let go of the sticks, check how speed/height control performs.

@mgrimes1907 still trying to figure what the issue with your wp file is, might be some issue with wp extraction from the log-file as @Rolf has stated before. could you maybe upload the actual wp file only?

The TECS parameters themselves are not the root cause, as I thought at the beginning. Only after that I noticed the much too low value of TRIM_ARSPD_CM.

Wiki: https://ardupilot.org/plane/docs/airspeed-parameters-setup.html

That does make sense. I will change it and try this afternoon to see if it has any affect. I hope that is it. I thought that the TRIM_THROTTLE being at 45% would have kept the plane at cruise speed though. Maybe that is only if there is no airspeed sensor?

If an airspeed sensor is present and activated (ARSPD_USE,1), TRIM_ARSPD_CM is used as cruising speed, where TRIM_THROTTLE is the throttle position (0-100%) to maintain this cruisingspeed while in level fligtht.

As far as I know, without airspeed sensor or deactivated sensor the controller tries to keep the speed in the middle between ARSPD_FBW_MAX and ARSPD_FBW_MIN using both synthetic airspeed and TRIM_THROTTLE.

Good Luck

1 Like

Just had enough daylight to test after work. You were right. It took off and climbed to 112 feet and leveled off around 106. I need to recalibrate my airspeed sensor. I want the plane to cruise around 45 MPH. I have my TRIM_THROTTLE set at 45% which should be somewhere around the 45 Mph. TRIM_ARSPD_CM is set to 1780 which should be around 40 Mph. My AIRSPD_FBW_MAX is 22 or 49 Mph and AIRSPD_FBW_MIN is 13 or 29 Mph. I have the THROTTLE_NUDGE set to 1 so I should be able to adjust the speed in Auto or Cruise by moving the throttle up or down. Is that correct? Yes I probably need to move both AIRSPD_FBW_MAX and MIN up.

Thanks so much for the help!

Glad to hear its working.

Yes, that is correct.