Servers by jDrones

Arduplane 4.0.5 RTL Turns off Engine

Hi All,

I have an older px4 (circa 2014) – i flashed it from a copter and am putting it into a fpv wing with one motor.

I have a dragonlink plugged into the RC In of the pixhawk, with the ESC going into servo 3 of the pix hawk for the throttle. (elevens are plugged into input 1/2 of pixhawk). Servo 3 in mission planner is set to 70 for throttle.

I am trying to set up the failsafe, but when I turn off the RC, it does go into circle—> RTL, but the engine completely turns off.

I have tried my other L9R receiver and even a different esc that I know has worked fine before, but they all have the same result: engine turns off when RTL is engaged. This happens even when I switch from FBWA to RTL.

Any suggestions? Could it be that the pixhawk thinks its already “home” or not moving/flying so it turns off the throttle (I am testing on my workbench)?

Your futile attempt fools noone, especially the Arducopter.
It is most likely just detecting a crash, because it can’t control it’s attitude as expected.
Bench top running is not a thing, it needs to fly or run in proper simulation.
Make sure you follow all setup guides, and do actual flying, then test Loiter and RTL, always being ready to take over in Stabilize mode till you know the setup is good.

1 Like

Thank you! Your response is appreciated!

Servers by jDrones