Servers by jDrones

ArduPlane 3.8 Beta 6 Telemetry Issues (RFD 900+) in Mission Planner 1.3.48.3

pixhawk
rfd900
pixhawk21
telemetry
missionplanner

(Alexander Perez) #1

Hello. Is anyone having issues with their telemetry radio antenna using ArduPlane 3.8 beta 6? I’ve been using 3.7.1 without a hitch for the past couple of months. I have an RFD 900+ radio telemetry and now I can’t get mission planner to connect (under 3.8 beta 6). I’ve tried it on two pixhawks (legacy and 2.1). I managed to make it work in a legacy running previous FW (3.7.1). Anyone out there experience something similar?? I’ve tested the radios in the stand-alone rfd configuration utility and they seems to connect without an issue. In the SIK radio setup in MP, the radios are able to communicate as well. However, when trying to make the communications link, it simply gets a time-out and unable to listen to a heartbeat.

On a final note, I’ve tried flashing previous versions of the RFD firmware (v1.13 and v1.9)

I would appreciate anyone’s feedback on this.

Thanks


(Alexander Perez) #2

Hopefully I can get some feedback on this. I just wanted to add some additional info for reference. I’ve upgrade the RFD900+ to the latest firmware (v1.13) and still no luck connecting. However, I’m seeing something odd. It seems it is partially connecting given I’m seeing a connection strength percentage on the screen and some messages displaying on the HUD. Yet, it is still timing out and getting the “No Hearbeat Packets Received” message. See screen shots. I’ve also included a screen shot from the Sik setup window for reference. Thank you in advance for taking the time to help sort this out.

Alex


(Alexander Perez) #3

After some trial and error with various RFD900+ firmware versions, I am able to get “something” or a reaction from MP but still nothing. See screen shot. Throughout this whole process (despite which ever firmware version I am using for RFD900+, I have been able to get both antennas communicating but MP still cannot connect. I’m in v1.9 and it is able to get some some type of connection but it locks up while first loading and reading the parameters. It stays stuck in GND_ABS_Press. Is there a serial communication issues perhaps in Mission planner and the new firmware? Just trying to throw ideas. Lastly, the connection is not consistent. Sometimes it connects (although still freezing while importing the parameters) and other times, it just times out without a heart beat. Your input is greatly appreciated.


(Alexander Perez) #4

Just another update, I’ve re-installed plane 3.7.1 and RFD900+ works flawlessly. Therefore, the issue seems it’s not with MP but with 3.8 beta 6. Go figure, the Octa QuadPlane issue with buzzing servos got fixed in latest beta but creates issues with RFD900+ telemetry connection. Any solutions in the pipeline?