ArduPilot (4.1.0beta) QuadPlane - QGroundControl Waypoints missing VTOL

Hi All,

I have a working QuadPlane (4+1) and am wanting to migrate to a tablet for waypoints and have access to Apple and Android. I know there is a beta of MissionPlanner for Android and it didnt work well for me on my devices, so I am looking at QGroundControl.

With the ArduPlane connected, the system links, etc. But when I plan a mission it is an aeroplane/fixed wing only. Its not appearing as a VTOL…

What am I doing wrong?

Not sure if this means anything, but i had to set the param “Q_MAV_TYPE” to “VTOL_QUADROTOR” (Default was “AUTO”), else QGC detected it as an ArduPilot Fixed Wing.

But QGC now has not SAFETY or FENCE options (not supported)

After many hours of testing using Mission Planner, it seems our build of 4.1.0dev (Nov 2020 dev build) on the cube is likely the cause.

Even mission planner cannot set the geofence.

It’s a bug in QGC, still contained in the most recent version (V4.1.3)

I fixed it for our QGC with the code in the graphic.
Previously there was a fixed set of APM Firmware commands. Now the commands are filtered by
vehicle class. However a VTOL often is defined as fixed Wing, and changes it’s type during fly
with VTOL transition command.
So from my understanding a fixed wing must contain the VTOL commands, too.

I don’t think that is correct nor is this change. This:

This should fix the problem and tell QGC that the vehicle is a VTOL.

I’m Also having a issue with this in QGC, it doesn’t let me put the transition direction waypoint ( tried in both PC and android) it seems like its on top of launch waypoint, , it tries to take off like a fixed wing aircraft (Not VTOL), But if I select Pix4d VTOL instead of Ardupilot VTOL it lets me set the transition direction, What am i doing wrong here?qgroundcontrol issue (2)

1 Like