Arducopter Holybro F7 AIO S.Port has only partial telemetry working

I am breadboarding a new setup to try using less expensive hardware for Ardupilot:
FC: Holybro F7 Kakute AIO
GPS: Beitan BN880 GPS+compass
Ardupilot 4.0.7
RX: Radiomaster R168 running FRSKY D16 with Sbus, s.port
TX: Radiomaster TX16S
Sbus receiver output to R6, S.port to T6

Basic arducopter function seems to work: all sensors recognized, RC radio working, Mission Planner working, etc.

Trying to set up FRsky telemetry and it only partially works. I get the RC receiver sensor values and only the GPS from the flight controller. The rest of the flight controller information is missing.

I followed the instructions for setting up the telemetry as follows:

" FrSky Telemetry is supported using the T6 pin (UART6 transmit). You need to set the following parameters to enable support for FrSky S.PORT


I have tried various other setups - different UART, different Serial Options, tried F.port setup, googled to death, etc. I don’t have one of the special cables for FRSky telemetry but you are not supposed to need one with F7 controllers like Kakute.

I only get the RC receiver telemetry at the transmitter plus the flight controller GPS. So some of the telemetry from the FC seems to work, but not much.

Can you help me?

You’ll need to install the Yaapu telemetry script on your Radiomaster TX.

One advice. I’d stay away from BN-880 GPSs in an ArduCopter setup. The least I’d go for is a NEO-M8Q.

Thanks. I have the yaapu scripts, but was following a youtube tutorial and they said that you needed to verify that you were getting the raw sensor data via the opentx before trying the scripts. The video showed that the presenter had lots of sensors at the opentx transmitter in the telemetry page, then he was going to install the scripts to intepret the data and display it. Thanks for the advice on the GPS, I thought it was a decent piece of gear but will try to get a better GPS.

Youtube video, pfft.

You don’t need to do anything with raw sensors. For most applications you don’t even have to discover sensors. Follow instructions on the Yaapu Wiki.

Thanks, you were right, in the case of Ardupilot, you don’t see a lot of sensors. However, after following the wiki and youtube video, I was able to get telemetry working.