Arducopter fast drifting in stabilize mode

I have owned a apm 2.5 for nearly a year now first on a turnigy H.A.L which was a mess and made me lose all hope in apm after months of trying to fix it.
then i made the decision to change the frame to a f450
and to my surprise it did wonders it managed to fly(sort of).
I had trouble with inverted compasses , failed radio calibration, vibrations and more.
I managed to fix these however i could not fix on thing,
it drifts all over the place in stable mode
and not your normal wind drift,
it will speed up quickly while going to the side.
autotrim only made it worse and it will drift to the other side
so i tried to manually trim it.
when i trim to the right it will first overshoot to the right and then go hard left again(if it drifts right it will do the same if i trim left)
in loiter you can see it struggle against the drift(it wants to move to the left)
my copter can’t hold alt very stable,which i think is a result of the drift.

quadcopter specs:
multistar 2216 800kv
30a afro esc
12x4.5 prop
f450 frame (originally turnigy H.A.L)
2x 5000mah 3s (i use a second one for added weight otherwise it is very overpowered and bounces around
without a camera)
apm 2.5+gps/external mag+power module+bluetooth telemetry
flight time 22min(longest flight i did )

the quad is level in mission planner and real life
all trims are reset on my tx
all esc calibrated all motors run in sync
all calibrations done multiple times(compass, compassmot, accel ,radio)
did autotune(very smooth response)
treid auto trim and save trim did not work
vibrations are between 3,-3

i hope some one can help me
i managed to fix all those problems
but not this one and i am desperate :cry:

thanks for ready


Please provide tlogs and/or dataflash logs to help troubleshoot your issue.


Here is an Auto Analysis of your dataflash log:

Size (kb) 4126.8505859375
No of lines 55089
Duration 0:11:12
Vehicletype ArduCopter
Firmware Version V3.2.1
Firmware Hash 36b405fb
Hardware Type
Free Mem 0
Skipped Lines 0

Test: Autotune = UNKNOWN - No ATUN log data
Test: Balance/Twist = GOOD -
Test: Brownout = GOOD -
Test: Compass = GOOD - No MAG data, unable to test mag_field interference

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERR found: FS_BATT
Test: GPS = GOOD -
Test: IMU Mismatch = NA -
Test: Parameters = GOOD -
Test: PM = GOOD -
Test: Pitch/Roll = GOOD -
Test: Thrust = GOOD -
Test: VCC = WARN - VCC min/max diff 0.326v, should be <0.3v


Don’t know if you have tried but, is there an option for autotrim on your version APM? I have a mini 3.1 that will. Maybe try that feature to correct the drift. Good luck.

As i stated i my first post,
autotrim only makes it worse
i treid constant adjusting on the sticks and small ticks
it is ultra sensitive in autotrim mode ,
but that is supposed to happen i believe

[quote=“ccccc382”]As i stated i my first post,
autotrim only makes it worse[/quote]

Yeah, I missed that, but have to tried the autotune yet? Props balanced? Is the FC mounted on vibration dampening? Trying to imagine this happening and what I would look into…

Autotrim worked as described on my ZMR250 so I am thinking maybe a vibration issue.

as stated in the last part off my first post
i did auto tune ,this made the pitch and roll smoother.
the vibration are below 3,3-

you can see it in the log

i have been through the process of solving this problem for some months now
and it is making me desperate

[quote=“ccccc382”]it is ultra sensitive in autotrim mode ,
but that is supposed to happen i believe[/quote]

When I go into autotrim mode, I do not notice any difference in flight characteristics. The instructions say to hold the bird as still as possible for a time then land and it saves the new settings. I assume you have tried autotrim mode more than once and am curious if the drift changes with each time you make new setting saves? The only other trim options are in your TX. Not the trim at the sticks but sub-trims in the menus.

thanks for your suggestion
i found out there was a set subtrim in the menu and hoped it was the problem.
i removed them and recalibrated my esc and radio(in mission planner )
sadly it was not
the quad drifts as bad as before
even after i did multiple auto trims(nearly uncontrollable)
it gave the same behavior as before
but now it looked a bit like it drifts hard in the last direction i pitch or roll(cant say for sure wasn’t a very long flight)
i surely am not in rate or acro mode
just stabilize mode