Servers by jDrones

Arducopter drops from the sky on landing [solved: was battery failure]

Hi, can you help me understand why my arducopter just fell from the sky when I was landing it? So I was trying the new fpv system I put on my drone, all was fine for like 14 minutes, then I saw the battery getting pretty low, and returned it manually (in loiter mode), I started landing it, but then like 5 meters above ground it started falling really fast, I switched back to stabilize and went max throttle but the motors didn’t start spinning faster! Note: it wasn’t disarmed! Luckily the crash has been avoided, and it just hit the landing gear hard. After it fell, I touched the fpv and it was hot as was the LiPo. The vtx was touching the apm board and maybe it happened because of overheating the board itself, not sure about that. And I also want to point out that it was the second time flying with fpv, in the first flight happened the same thing but it already almost landed. Also the voltage on the lipo was not lower 3.4V / cell, I had a voltage alarm. I attach the log file, maybe you can find something in it. In the log there are 3 flights, so you will see 2 or 3 landings. I think you can figure out which one is the one where it fell by altutude change. Also after the crash I tried to take off in loiter and it worked just fine!

2021-01-27 17-56-53.bin (920 KB)

Probably battery failure.

Even when the battery monitoring and failsafes are set correctly, some ESCs also do their own reduction of power (or total cut) when battery voltage falls below a certain level.
I would definitely set up battery voltage, current monitoring and failsafes, then disable whatever voltage related setting the ESCs have. If you cant disable it in the ESCs then set arducopter to failsafe and land before the ESCs interfere and cause a crash.

There’s very little information recorded in the log file. There’s a few problems that stand out though:

  • Not waiting for a GPS 3D fix, looks like you travelled about 20 miles (when you didn’t) - this has the effect of not setting Home position and not being able to RTL, also aggravates a fly-away situation.
  • No battery voltage and current info, no failsafe set.
  • Arming checks disabled.

image
image

ARMING_CHECK=0 -> disabled, Set to 1
FS_BATT_ENABLE=0 -> disabled, check and fix battery monitoring then set to 1
GPS_HDOP_GOOD=230 -> too high, needs to be 140 I think
LOG_BITMASK=894 -> 45054 (or even -6146)

It might be time to update the flight controller hardware and firmware version. Even thought the old stuff can still work, there’s so many important fixes in later versions…

My apm 2.8 supports only version 3.2.1 of the firmware.

Also, the logs are not correct, because I made 3 flights today without disconnecting power and I can’t see them in the logs, I also waited for GPS lock before taking off… And I used a lipo alarm set to 3.5 volts per cell that didn’t trigger, so the voltage didn’t come down to that level. Not sure what was wrong there, I will do some testing, I still believe it’s the overheating caused by the vtx

This happens AGAIN! Please someone help me figure this out, this time I have a video recording from the drone and a proper log. 2021-01-29 18-07-49.bin

Video with the crash HERE

What could this be? This time it didn’t stabilize while falling…
Check the logs please, maybe you will find something.

Any help will be appreciated!

Sadly the APM didn´t take a lot of data on the loging, RCOUT is need it in this case. The voltage and current are not good either.

how much weight your craft? what motors and props are you usgin? May be a picture of your drone will help

When i was starting with drones, I remember I had this same issue. Better to move on toa pixhawk, that way you can have the last updates and a log full of data.

bye

1 Like

@alberto.munizaga I will try to fly it tomorrow and test if the issue still hasn’t gone, I have moved the fpv vtx away from the apm after the crash, because it heated the board, I will also check what data is recorded in the log, maybe I will check everything.
This is a photo of my drone: The weight is 1.9kg

what about the power APM jumper? did you remove it? the JP1

imagen

1 Like

No, do I need to remove it? What does it do? @alberto.munizaga

That Jumper is there to give power to the ESC (I never knew this kind of ESC), so if your ESC has BEC´s, could me a problem. You have to remove it to ensure avoid electrical problems.

1 Like

My ESC’s have a BEC (5v out) and I will try to remove the jumper and test it as soon as possible! Thanks for your help! Will update you on how it behaves when I test it!

So now after removing the jumper, the quadcopter doesn’t arm, it says High GPS HDOP. Maybe it’s broken GPS after a crash, or maybe because of the jumper, not sure. Tomorrow I will put the jumper back where it was and test it again.

If some of those changes cause electronic noise on the GPS, then you will probably get a high HDOP because of a low sat count.

@amilcarlucas The sat count was high (more than 10), but maybe my power module doesn’t give enough power to the GPS, I said, I will try it tomorrow!

Normaly the HDOP has nothing to do with the jumper, unless the BECs from the ESC were powered your APM board, and the PowerModule you have cant give enough power to turn on the APM and GPS.

your telemetry and RC receiver, where are they taking the power to run them? from the APM or are you using BEC´s to turn them on?

2 Likes

My RC receiver is powered by the apm

I strongly recomend you give energy to your periferics from an external power source. You can use a 12V or 5V BEC, or if your ESC has 5V BEC, you can use that one (of course will depend of your current usage).

1 Like
Servers by jDrones