Arducopter continuously shows DISARMED?


I am working on a Quad450 with Pixhawk, firmware version 4.0.5. I am facing the following issues. I have a PPM Transmitter with an Encoder.

  1. ESC calibration is not getting successfull from the Mission Planner ESC Calibration. So, I do not know whether my ESCs are calibrated or not.

  2. I have a safety switch. I pushed the button, still the HUD says, DISARMED.
    For this, I tried Right Rudder arming, which did not work. I have also tried with ARM CHECK disable for Safety switch (as it was showing Hardware Safety Switch in the message, even when it was pushed). I changed ARM required to 0, 1 and 2. But nothing worked.

I have done motor test and all the motors are working. I manual corrected the CCW and CW parameters.
At this point I am just testing without propellers and I tried doing all these things by keeping my drone indoor and outdoor. In outdoor, it got 3D DGPS too.

Requesting a speedy help. Thank you.

you need to reboot after changing some of the parameters for the changes to take effect.

1 Like

The Safety switch does not arm the motors. The safety switch ALLOWS you to arm the motors.

Post some pictures that show how you have the encoder connected to Pixhawk and to the receiver, and also show us how you have the ESCs connected to Pixhawk.

What radio and receiver are you using?
Did you run the internal calibration of the stick gimbals on the radio?
Did you run Radio Calibration in Mission Planner > Setup > Mandatory Hardware > Radio Calibration?


Right. The safety switch does not arm the motor. However, the Right Yaw stick was also not arming the motors. So, that was the reason behind asking that. I have resolved this issue of not arming with Right Yaw as I have now assigned a separate switch/channel for that and it is working fine.

I am using FS CT6B RC pair.

Sorry. I did not get what is the internal calibration of gimbal sticks on the radio.
I have done the Radio calibration.
The ESC calibration is what I am still doubtful of. As I have followed the processes described for ESC calibration however, the response of saving the higher values and lower values by beep sounds, have not been received.

With arming things resolved, I armed the motors and all the motors are operating - starting and stoping altogether.

I retried calibration all my ESCs in one go as per Mission Planner instructions. I did identified the tone that comes up after calibration. However, I don’t think it is working fine.

The drone is balanced when I check the balancing. However, when I apply throttle after arming - it flips on the backside. I feel that the rear two motors are not calibrated properly.

This is always incorrect motor rotation and/or numbering.
Double-check this:
and use the MissionPlanner motor test, where the “lettering” (clockwise from front-right) does not match the numbering.

1 Like

Thank you so much for your point.

Basically, that mistake was due to the ABCD thing. Need to be careful.

Thanks a lot for the help. The issue is resolved.