Arducopter barometer all over the place

I am using a Kakute F7 flight controller with his own barometer. However the last flight, the barometer was all over the place. By that I mean that the quad was 4 meters in the air, and the altitude was - 2 meters. The weird thing is, when placed on the ground and connected to the battery, the craft always has -0,3m altitude. This is the picture from the log analyzer for altitude.

And then this is the picture for the temperature.

The board is placed like this.


Today was a bit windy, but this happens sometimes even when it is not.

And here is the log.

It looks like you have some foam sandwiched between the board and frame. Right?

Yes, you think the board’s heat could be the problem? The foam is between the gyro and flight controller, under the flight controller there is no foam.

I have the same problem but with matek F405 CTR. I can’t find any solution even with the thermal compensation of the barometer

Just did a test, measured the distance. It was about 30cm, and at the beginning, the board was about 20cm off, but when the flight controller was heating up, the baro was jumping from 0,5 to 1,6m in height. How would I solve this?

try this?

I just tried this, but now it goes into negative options. If I leave it like before I get about -2,30m.

Haven’t got good baro readings from BMP280. Try MS5611 via I2C.

The Kakute F7 is feature limited and one of those features is external I2C Barometer. You would have to compile a custom version and get rid of something else.

Unfortunately the Kakute F7 only has 1 availible I2C pinout. And that one is used by the external compas.

That wouldn’t necessarily prevent you from using an external barometer if the I2C adress is different than the compass. Which it probably is. But in any case it’s not supported in current firmware. That’s true of most, but not all, 1Mb flash boards.

I think I have found the problem. If placed on the ground and given some throttle (not enought for take off), the altitude will slowly start rising. Will try to put a piece of foam over it, so the wind doesn’t directly hit the barometer.

Accidentally I just tried this today, and actually I do get a correct initial temperature reading from an I2C GY-63 MS5611. It doesn’t seem to change however. Is that to be expected? I intended to use it as thermometer only, not for altitude.

Well, that’s interesting. Do you have a GND_PROBE_EXT parameter? I think you would if you were running Master (Dev version) but I don’t think it’s there in current stable V4.0.3 on the Kakute F7’s

Yes I do and I’m running Master (for now) because of something else I wanted badly. I think it was either CRSF or Runcam Control or both (the latter didn’t work even with Master though, cam is not recognized).

Is it worth trying to make the initial value actually change or should I better forget about it and put the MS5611 on my next build (F765)?

You should be able to get that external baro working and if you have a place to put it on the craft would be advantageous.

I too run master for the FFT referenced Notch filter and bi-directional frysky telemetry/GCS.

Which board are you running?

Kakute F7 1.5 AIO. But it’ll be a while until it (hopefully) flies, haven’t even unpacked the frame yet. That’s why this thread caught my attention. I have the same FC in an iNav quad though and baro is not jumping there.

I did, however, have massive jumping baro issues earlier this year with a Matek F405-CTR which I never fully resolved. In the end I put BF on it because for some reason it was jumping less there than on iNav. I didn’t try Arducopter then because I would have had to take it apart and rewire things and that little quad had already taken up too much time.

I solved my problem. As I mentioned above, I suspected the problem to be the space underneath the flight controller, where the wind from environment and propellers was coming in. That is also the location on the barometer. I put a piece of foam under the flight controller, just enought of it to block the direct wind. The craft now does not just change from 4m to -4m anymore, and flies good in loiter and alt hold mode.

I asked about that several posts ago, thought you said you did that. I discovered this with that FC and a Omni F4 Nano. Foam is mandatory.