Arducopter 4 on Omnibus f4 v5.1

Can I use this board for Ardupilot? Tries using the various firmware’s available to load(with Bootloader) using betaflight, but it hangs and won’t complete. Tried f4, F4 Pro, and others, but no luck. Does this board require a different file? I have done this successfully with an earlier version of the f4 ( v 2 or 3 I think), but this one is fighting me.
Thanks, Joe

You can…

Did you download latest version of MP and the latest firmware?

You can try custom firmware upload…

I don’t think Airbot produced a V5.1 of that board so I suppose its another Omnibus clone. ~$25$ Or less? But the IMU is supported so I suppose it should work.

@dkemxr, Having tried everything I could think of and Googled,I loaded a OLDer version of Betaflight Configurator, I was able to successfully flash the copter version of code with the Boot loader without it hanging during the flash phase. Why the newest version of Betaflight Configurator didn’t work is beyond me. But finally got it working. Back to MP!!
Thanks to all- now if I could get this day back!.

I was going to suggest an ST Micro flash tool to try but sounds like you are in business Joe!