Arducopter 4.0 Heli Testing Thread

Curious if your temp probe is downstream of the N2 (EGT) or downstream of Ng (ITT). There is a large temperature and pressure gradient between those two stages of the engine. If the FADEC is using EGT with ITT specs it is very easy to over-temp the N2 spool. Like a PT6 idling at 470C ITT, you can lay your hand on the tailpipes without getting burned. A good portion of the heat is extracted in the N2 power turbine and converted to shaft power.

This would be another issue with trying to autonomous start one. Some use EGT, some use ITT, some use TIT downstream of the combustors/upstream of the Ng turbine, and the temperature and pressures drop at each stage of any turbine engine. The flame from the combustors never actually touches any part of the engine internally, including the combustor liners. If it does, that’s what causes the damage.

Well Chris, I have no idea without looking it up, that’s a great question This is a test platform using a Wren 44, and were at 6000’, on a hot day density altitude easily reaches 10000’, it has a 3 blade main and 3 blade tail rotor. The tail has 130mm blades so it has plenty of authority.

Ok, nuff said. Wren 44i/50i is ITT, but they call it EGT on the DT.

1 Like

Guys can we take the turbine starting discussion to another thread?

Sorry Rob, will do. I was thinking the same thing. I apologize!

Is there any way a admin could move the turbine stuff to a new thread, maybe named Turbine Heli’s ?

1 Like

Trad Heli Users,
AC 4.0 rc 3 was released yesterday. here is the post. There was significant change that I wanted to pass along. I put the IM_STAB_COL parameters in percent rather than percent * 10. when you upgrade to AC 4.0, the parameter will be converted automatically

Other changes were strictly to the parameter display names and descriptions. @ChrisOlson has been working on QGC to make the heli page compatible with AC 4.0. I will be working with @Michael_Oborne to make the heli page in mission planner usable again. I don’t expect that will be ready right away. I am working with Michael to update the page layout.

Lastly the SITL version of autonomous autorotation was merged with AC 4.0. For now it only works on SITL with Realflight and @IAMMATT has it performing the entry and glide. He is currently working on the flare algorithm and control logic.

that is all for now.


I have QGC’s heli setup mostly done, and that is in the Daily Builds at present for 4.0 rc’s. I had to put a version control in QGC because 4.0 is not compatible with 3.6. So for helicopters running 4.0 or newer the heli setup will display in the next-gen QGC ground station, but it won’t display if the firmware version is 3.6.x or earlier. For helicopters running ver 3.6.x you will have to use the current QGC stable build.

I will also prepare a couple short video presentations for the ArduPilot channel and wiki explaining the new swashplate and throttle/governor setups. I think the PR is in for the latest param description improvements, so should be able to get to that when the XML is updated in QGC.

1 Like

I asked this in another traditional heli forum but I tried version 4 and had to roll back because of missing RSC channel 8 throttle control missing in ver4. In the latest version of firmware (arducopter trad heli), with the latest QGC there is no longer an option to set channel 8 to throttle output so I can tie it to a knob. I rolled back to QGC 3.5.6 and it returned, but I had to re-flash the older firmware (arducopter-heli-stable-3.6.12) manually (which I dont like doing, I like QGC to find the fmuv2 version on its own as its safer than manual updates).

Is there any reason for this change and I missed the note somewhere? I cannot use arducopter without this ability and I tried to map it through the full param list but it didnt work. I left it on the older QGC and older firmware but ideally I would like to use the latest version.

Hi Josh,
We changed the name in 4.0 because it is no longer tied to channel 8. It is now called RC passthrough. The user now has the option on setting the RC channel for the motor interlock and the RSC passthrough mode follows that assignment where as in 3.6 it remained tied to rc channel 8.

Thanks Bill, I figured there was a reason but I couldn’t get it working. I originally tried the passthrough but no luck. What do I need to change with my config to get it working? If I set it to passthrough with my radio programmed to use channel 8 (tied to knob) same as in the older firmware but it doesn’t work so I’m missing something somewhere. Rolling back to the previous version works perfectly with the same radio config so I don’t understand how to get it working.

You have to set the RC Option for channel 8 to motor interlock.

@GROOVY1975 that should have all upgraded without you doing a thing.

It didn’t upgrade with the firmware and I had no throttle output. I did the firmware upgrade exactly as I do all firmware upgrades, the firmware upgraded without issues or errors and I had no problems with the firmware update but it didn’t have any throttle output. After I couldn’t get it working with the normal config (that works fine on the older firmware), I tried everything, using all RSC options in the new 4.0, I even setup a new model in my radio. Nothing worked until I rolled back to the previous firmware (using the original radio model), then without making any changes it worked fine but only on the older firmware.

So if you are still having problems then send me a param file after the upgrade to 4.0.2

Will do when I have time to go through the upgrade process again. Currently I’m on copter, stable-3.6.12 without any problems (using the previous version of QGC). When I’m ready to test again, I’ll go through the firmware update and send you the param file.

I did the updates to QGC for 4.0. I deliberately made the 4.0 version of QGC incompatible with 3.6.12 and earlier firmware due to too many changes in the settings.

I will double-check it to make sure I didn’t accidentally leave something out in QGC. It was some weeks ago when I did those updates and I had bench-tested every setting to make sure it sets the proper parameters. But I will double check it again.

I loaded 3.6.12 in my Trex 500, put the old param file in it and got it running. Set up the throttle with RC8 input instead of Setpoint, which I had been using in that heli.

I started up QGC 4.0 and did the upgrade to 4.0.3. Had to recal the accels for some reason. All the params scaled to the new settings correctly, the throttle worked on the first try, didn’t have to set anything.

So at least no problem detected in QGC. Don’t know if it would work, though, if a person upgraded to 4.0 using the older version of QGC. It would upgrade the firmware version, but the settings shown would not be correct as the ParameterFactMetaData xml’s are different between the two.

I had it same as your RSC config, it was set to RC Passthrough but it wouldnt respond to throttle (cyclic pitch lifted and lowered with throttle left stick up and down) but no output to motor from channel 8 (tied to knob) nor the throttle joystick (gimbal), power was just not being sent to thr motor. The knob is programmed in radio as chan8 for throttle and works when RSC is set to chan8 on the odler firmware.

I then take the same config and roll back to the earlier firmware (3.6.12) and it works fine with no changes so I am not what happened but I havent retried it yet again. It is flying so darn well on 3.6.12 that I am pushing it off until its needed.

Just a head’s up, still not working with the very latest firmware (4.0.2) and the latest GQC and it still has no throttle output from the RSC (channel 8). Only reverting back to the 3.6.12 firmware works again. The second I roll back and apply my default settings, it all works fine.

This was NOT an upgrade of 3.6.12 but a FULL firmware re-flash (I went to plane, then heli so it wiped the device). No options for the channel 8, and pass through came up by default but didnt do anything. In fact, I couldnt get throttle on anything but T-Curve. When I rolled back, it follows channel 8 and works fine.

@GROOVY1975 please send me a param file from 3.6 set up and then the param file once you upgrade to 4.0. That is the only way I can help you.