Arducopter 4.0 / 4.03: Auto Set_Servo_Command Not Working

Hello All,

I have a hexacopter and I’m trying to have a servo open / close during an auto mission.

  • I have it on Channel 7.
  • On my Futaba / Dragonlink set-up, the servo opens and closes on a manual switch with RC_Passthrough.
  • In the parameters, for the auto mission, I set Servo_07 to 0.
  • In the flight plan window, I choose the option of Do_Set Servo, on channel 7, and and it set to 1, as well as 0. When I execute the mission, the servo does not want to move.
  • I have tried Relay as well, with no success.
  • On the main flight page, I have the servo set up and it works manually there too.
  • I have done this on Arduplane, and it works everytime, but not on Arducopter. Any suggestions? I have updated the Pixhawk from 4.0 to 4.03, with no luck on either. I’m running the most current version of Mission Planner.

I’d appreciate any insight. #arducopter #development-team

1, 0 ? do_set_servo requires pwm value, so try 1100 or 1800…

1 Like

Hello @Eosbandi,

Thank you! The PWM was the solution! Worked like a charm :smiley: