Arducopter 3.4.4 Cam Trig issues

I have been tearing my hair out for the last few days with one of my mapping machines.
Story condensed: Our everyday machine that has done heaps of mapping work … all of a sudden had “Accelerometers Inconsistent” message so I decided it was time to upgrade from 3.3.3. to 3.4.4. and redo all calibs. Then during testing we noticed the camera was now firing too many times during “auto missions only” more than the cam messages in the logs … so we ran numerous tests on the camera and it checked out OK … tested the trigger relay cable OK, I tried setting in params for the copter to take photos every 12m and jumped in the car and drove around… tested all good …then I did a flight with the same settings this was all good and everything matched… But when planning survey mission in MP.44, loading it and flying it we are back to more photos than cam triggers again … its almost double the photos some times 3 or more ??? .Seems fine when triggering manually from MP or RC… I am at my witts end :frowning: I even tried a different version of MP .41 on another laptop and tried going back to 3.3.3. but no joy .still now doing the same,.this has never happened before its always been very reliable.

Ever heard of such an issue??..

Best regards Reuben

Do you think the camera is firing too much or do you think there are missing CAM messages?

Hello Buddy !

Just the man i need !

No the cam messages are just the right amount when planning a mission you always get more triggers than the auto grid tells you i.e … the auto grid says the area will take say 45 photos but you always end up few a few more in real life like 47… thats ok . what has happen is after the update to 3.4.4 the camera now takes twice as many photos as cam messages …the cam messages match roughly to what the auto grid worked out …so for the life of me i cannot see whats up … the only changes i made where to update MP and then Arducopter…to 3.4.4

I don’t see my attached log in my message ?

Just to let everyone know how I fixed this issue so this case can be closed,

I found out that the signal from the Pixhawk was somehow affected, giving a dirty signal to the camera and the fix was to add an extra earth (ground) wire from the trigger circuit to the battery on the gimbal.???
Now for the life of me I cannot see why this fix was necessary as the copter was flying very well for months and months doing many missions with out issue “UNTIL” the day I upgraded to 3.4, .next minute on the first few test runs this problem was found.

1 Like