Arducopter 2.6 can't update firmware

I am using a win 7 computer and Mission Planner
I have tried 3 different computers and 4 different USB cables. I can connect to my Arducopter 2.6 in the flight data screen (Mavlink) - tip my copter in all directions and see the correct change in attitude in all directions. When I try to run the Accel calibration from the initial setup screen it hops through each of the six positions in about 2 seconds then displays calibration failed. I have successfully calibrated my accel from the terminal so when I am on the flight data screen attitude look good, level looks level.
So to sum it up I can connect with:
I can’t:
Update my ArduCopter to the latest version
Fly my Quad (it tries to flip forward violently)
I did have a KK2 board that I was able to fly with just fine - want to move up to GPS and Way points
I did note the difference between motor connections between the KK2 and the Arducopter and have connected accordingly.
Thanks in advance for any assistance you can give me

you are running the latest AC firmware?

I am attempting to load the latest firmware. It errors out while reading hex. I get a communication error - failed to connect.

I had same problems. Turned out to be a bad connection at the apm usb port. Try updating whilst holding the plug lead firmly in the apm port. Worked for me :wink:

Thanks for the idea - still not able to update the firmware - I have tried several usb cables - They all work in the terminal - They all work in the flight planning screens.