ArduBoat Troubleshooting - not quite following mission path

It is not following a mission path very well. Sometimes, it goes in the right direction and takes a wavy path to the way-point. I changed the NAVL1_ period to smooth out the path. Other times, it just loses it mind and runs way off course and into the dock - ugh.

Mission Planner 1.3.41
APM 2.5 with External Compass
The boat is 6.5 feet long, powered by a trolling motor, and gear motor with JRK controller
Running Mission Planner on a Dell tablet that is installed in the drone that is directly connected to the APM unit.
I set up long range WIFI on the drone and can access it using a remote desktop. This part works beautifully.

Back to troubleshooting…

Have gone through radio calibration, accelerometer calibration and testing - manual mode working fine.

Worked through the documentation and corrected power issues, servo issues, communication issues.

Below are my settings:

TURN_MAX_G = 1.5
NAVL1_PERIOD = 22 (started at 18 and incremented to smooth out the wavy path)
WP_Radius = 3.03

Logs are attached and I could really use a fresh set of eyes to see if I am missing anything.



125 12-31-1969 4-00-00 PM.bin (1.9 MB)
125 12-31-1969 4-00-00 PM.bin.log (2.9 MB)

Did another round of testing and it is still not following the path.
Experimented with guided movement and it did seem to work a bit better but certainly not consistent.

Logs attached.

10-21-2016 5-37 -00-00 PM.bin (1.9 MB)

I have not looked at the logs yet but is the internal compass on the 2.5 disabled and what version of the rover code are you using. Also is STEERING MODE working well.

David R. Boulanger

Steering mode is fine.

“Fly to Here” is better than full auto.

Using ArduRover v2.51-beta (705d3d56)

Compass is on. Motor is a couple feet away from APM.

The electronics are running on one battery (5 ah) and the motor/servo’s are on own battery (35 ah).

First of all - Love to see a photo :slight_smile: Video too! I’ll have a look at the logs and get back to you.

Thanks, Grant.

I had a similar problem and it turned out to be the GPS.

  • With a plastic design, it simply didn’t have a good enough view of the sky (It was somewhat inside)
  • With the metal design, I found I had to mount the GPS flat on the metal, mounted up a few inches caused the position to jump all over - must be some type of reflected multipath interference, I don’t know, but it was solved by moving things around.

Moral of the story: GPS might be worth a check!

First of all try replacing your SD card in your Pixhawk the log file is fairly corrupted and the SDCard is the most likely culprit.
The mission in the log file is 3 waypoints all on top of each other. It could be that the corrupted log didn’t capture the mission correctly or perhaps the wrong mission was uploaded to the vehicle.
CH1 - the steering channel is reversed. I assume when you drive the boat in MANUAL mode you need to set CH1 to reverse on your transmitter otherwise it doesn’t steer in the right direction? If this is NOT the case then CH1 needs to be set back to normal.
Let us know how you go.
Thanks, Grant