Arduboat throttle left and right not showing movement in servo output bars

I am making a pixhawk boat which has two motors which would I want them to work in a differential mode as I donot have any rudder.
In the configuration setting I set the class to boat. changed the output to type of servo to throttle left and right. I didnt connected the battery and just wanted to see if I get any movement of the bars in the servo output. I armed the boat but the throttle bar didnt moved with changing throttle. The green bar stayed the at the same position as shown:

Changing the function to ground steering allowed me to change the green bar. Why isnt it working with the throttle??? Kindly help me in case I am missing something.

Hi @m_farooq,

What mode was the autopilot in? My guess is that it was in Hold mode so the throttle wouldn’t move. Try Manual or Acro and it will probably work.

@rmackay9 it was in manual mode when I tried it

The issue has been solved. The safety button wasn’t pressed earlier.

1 Like