Ardu Rover setup

Hello, I’ve recently put together a rover using a Pixhawk. I’ve got the Ardu Rover 3.1.0 firmware updated and I’m connected to it succesfully using the telemetry. The compass and everything are calibrated and working. My problem is when I arm it nothing is happening with the steering or throttle. I have 5V running to the servo rail. The only thing that happens is I have a second servo for four wheel steering hooked up into the RC5 port that goes clockwise all the way and I can control it with the roll stick of my controler. I’m using a Spektrum DX6i which is hooked up and radio calibration shows everything is working correctly. I want the throttle to work the throttle and the yaw to steer it. Any clues as to what I should do?

The ArduRover firmware is expecting the throttle to be controlled by the elevator joystick and the steering to be controlled by the aileron (roll) joystick.
The problem using the throttle joystick is that there will be no reverse available. The firmware is expecting neutral (stopped) at 1500us, full forward at 2000us and full reverse at 1000us. The throttle channel outputs only 1000us to 2000us with no reverse.

Ok I get that, what ports are the throttle and steering supposed to be hooked into? There was a sticker that says Rover on it that I followed and it has throttle in main three, steering in main four, then from a discussion on here I put the rear steering servo into main five which is the only one moving. Do I have them in the wrong ports or can I just go into parameter list and change them?

Ok so I have the four wheel steering working but I can’t get anything from the throttle. I tried a few ports and tried changing parameters to 33 or MOTOR1. Not sure if that’s what it’s supposed to be. I have two motors going to an ESC which then goes to the Pixhawk. Not sure which port it’s supposed to be plugged into or what parameters to set it to. Please help! Thank you for the help thus far.

I don’t know if it will help but I’m hooking it up to whatever ESC came with the Maxstone 1/5 scale crawler. I can’t find any specs on it anywhere so maybe I should just get a different ESC but that would be a lot of work and time. if you have any suggestions please let me know. Thank you!


Although I don’t have a rover I use the rover code in a boat. Steering should be main #1 and throttle main #3. If you have no throttle it sounds to me like you are not armed.

David R. Boulanger

@David_Boulanger Ok I tried that and got nothing as far as throttle. I have the front steering servo in main #4 and the rear steering servo in main #5. I figured out how to get the parameters set up so that they’re working correctly. Here’s something funny. I plugged the throttle into a few different ports just for fun and when I plugged it into main #1 it started working. Thing is it’s going forward when I turn to the left and backwords when I turn to the right…I tried puting the throttle into main #3 and got nothing so…I guess I’m doing circles lol

@TCIII Any thoughts or suggestions on what I should do?

What are your RCMAP Parameters? I Know nothing about 4 wheel steering parameters but main #1 would normally be for a steering servo.

David R. Boulanger

@David_Boulanger Do you mean like RC5_DZ and all of those under parameter list? I changed RC4 and RC5 to 26 for ground steering. They work great. I just can’t get anything to work the throttle and I’ve tried every port. The only one that works kind of is main #1 which has it going forward when I roll left and backwards when I roll right. The right joystick is my steering which Thomas stated earlier in the discussion is the designated stick for steering and throttle. so roll left or right is steering left or right and for some reason throttle as well. I don’t know how to make it so that Elevator up and down are throttle up and down…I think I’m going to try resetting everything to default and see if that will get it working. I’ll just have to rewrite the RC4 and RC5 back to what they are now…

I mean the four RCMAP Parameters. Also what receiver are you using?

David R. Boulanger

Ok sorry I’m new to this. I just reset everything to default…it was hard to do but we’ll see if anythings fixed.

Thanks for trying to help me

I don’t know if you are using a satellite receiver or full receiver with a PPM encoder or what.
Try pitch 3
roll 2
throttle 1
yaw 4
Make sure you are arming the system or try to changing ARMING REQUIRED to off ( vehicle up on blocks of course ).

David R. Boulanger

I have the front steering servo in main #1, rear steering servo to main #4, tried throttle to main #2 and #3 and had no luck. I also tried it with the parameters you gave me and that mest up my steering so I switched it back to default. Do you have a Pixhawk or an APM? I’m guessing nothing is the same as with most electronics. I’m taking off for the weekend so I’ll try again Monday. Thanks for trying to help


I use a Pixhawk.
David R. Boulanger

Will this be helpful to understand the scenario? Could you please fill the missing?
Transmitter type: Spektrum DX6i
Receiver type: ?
Autopilot hardware: pixhawk
Autopilot firmware: Ardu Rover 3.1.0
Transmitter setup
Pixhawk main channel output
CH1 -> ? for steering
CH2 -> ? for ? purpose
CH3 -> ? for throttle
CH4 -> ? for ? purpose
CH5 -> ? for ? purpose


Your RC map looks to be correct. Get a AR 7700 receiver and use the PPM output into the Pixhawk RC in connection. Assuming you have a mode 2 transmitter all should be well I think. Steering should be on output 1 and throttle on output 3 on the Pixhawk to the best of my recollection. You will be using the right stick only for throttle and steering.

David R. Boulanger