Servers by jDrones

APM2.X - Trying to Use ArduRover (need to change output pwm to 67Hz)


(Ahira) #1

Hello,

I am completely new with ardupilot and APM. After much research, I have realized I need my output frequency to be 67Hz. After searching the parameter list in Mission planner, I do not see anything related. I looked through the ardurover code on github and saw a variable in apmrover2.cpp that I can modify to make the change.

Questions: Research makes me believe I cannot load anything new, it must be AC3.1.2, but my mission planner seems to always load ArduRover 2.51 beta. Now I finally found the old ArduRover code, in arduino version but can’t find how to change output frequency :expressionless:

Also, I seem to be having trouble figuring out how to load custom firmware. Online, it shows in the “Initial Setup” will have a place to click upload custom. For me it does, but then while my COM port is being updated, it then suddenly disappears and seems like I cannot upload my own firmware.

I am very confused right now with multiple issues. Please help with any of them if you please can. I’m so new to all of this, that it takes hours to know what to even search and then not sure if I am on the right path cause there are so many options out there. I decided to post here to see if I can get direct help. Thanks


(Khancyr) #2

Hello,

sorry for late response.
About your plateform, it is an APM board right ? not a pixhawk ? In that case, the lastest release for that board is ardurover 2.50 .
I don’t know if much people will be able to help you on the old apm board…
Nevertheless, I don’t think there is simple way to change the pwm output. Moreover,about output frequency , ardupilot use RC PWM ouput at 50Hz, (that the pwm use to move the servo), by wanting to use 67Hz, I suspect you to aim to use normal PWM and not RC PWM so this will need to dig a little into the codebase to change correctly the output.