Servers by jDrones

APM2.8 unable to upgrade bootloader

I bought an APM 2.8 with periphery a while ago. I tried multiple times to change the output modes in
Mission planner but the settings are grey and inaccessible. Also I tried resetting it with no result. I can’t upload or update firmware ( board id error) or upgrade the bootloader. Please move this topic if necessary

Those have been obsolete for years. Throw it in the bin and replace it with one that Ardupilot currently supports.

For a boat an APM should be more than enough

It does not even run arduboat. Save yourself from hassle and frustration and get a modern FC. There are many low cost options available.
https://ardupilot.org/copter/docs/common-autopilots.html

It’s not a matter of “more than enough”. There is virtually no support left for the last version of firmware that runs on APM’s. Help questions posted about APM’s get few responses or none at all.

So what would be the best option? I think I could go for the cheapest that works with my sensors because I don’t need much performance and I don’t want to throw them away. Are all the FCs suitable for a twin engine boat?

If you want a similar form factor the cheap Pixhawk 2.4.8 's work. All your sensors will work but it (and all current FC’s) require PPM/Sbus input from the Receiver. There are many other choices if you want a bare board F7. A Kakute F7 AIO is one example. The AIO boards are easy to build with integrating several functions.

Servers by jDrones