APM with Jumper - USB power ruined board

I just received a second APM unit, tested it with USB as it came, then installed the Jumper and tested it again with USB, only to have the board light up, lights out, and usb surge message on my macbook pro.

I’m at a loss and totally gutted to say the least.

Is this previously documented? I can’t believe you would have to remove the jumper while connected over USB, and it certainly doesn’t mention it in the manual.

I did not have battery plugged in, however I did have the ext. compass + magnetometer plugged in.
Help or advice anyone?

@Cam Batten,
Having J1 installed on the APM depends entirely on how you plan to power the APM in your UAS.
Here is the Wiki section on powering the APM with and without J1 installed: copter.ardupilot.com/wiki/common … 2526_Board
If you are going to power the APM with the Power Module (PM) you do not install J1 as the PM cannot power the servo bus power rail on the APM servo outputs.
Did you have any servos attached to the APM servo outputs when you installed J1 and used the USB to power the APM? The USB connection should be able to power the APM, the GPS/Compass and an R/C receiver.
I suspect that your Mac cannot supply enough current to the APM and its accessories so you might want to try and use a powered USB Hub to see if your APM will work correctly.
TCIII ArduRover2 Developer


Some more detailed information that might help the problem:

Craft - Octocopter
Power - 6S, regulated through 5v/5A UBEC, measured supply voltage is 5.27v. (hobbyking.com/hobbyking/stor … ipoly.html)
UBEC plugged into output rail of APM, with J1 installed.
Measured voltage on input rail with UBEC installed - 4.99V

Initial power up was just USB power, no J1, via macbook pro (I have an existing APM 2.5 that I have used flawlessly powering via MBP with no problems). Initial power up and firmware update successful. Device connected.

Disconnected, USB unplugged, UBEC plugged in and powered up. Device LED sequence indicated supply was fine.

Plugged in GPS, Telem, JETI R18 ex + RSAT2 Reciever, Plugged in UBEC and powered on.

Could not achieve Mavlink Connection via Telem modem and MP.

Unplugged UBEC, left above peripherals connected, and plugged in USB.
All LED’s flashed and extinguished, over voltage warning displayed on MBP screen, USB port shutdown.

… APM no longer functional.



Let’s review what you did in the way of powering the APM:

  1. The first time that you powered the APM with the USB, you had not attached any peripherals.
  2. Using a UBEC on the APM output power bus you verified that you had 4.99vdc on the APM input power bus.
  3. Verified that APM would power up by itself on the UBEC attached to the APM output power bus.
  4. Attached peripherals and tried to power up APM using UBEC connected to APM output power bus and could not communicate with APM using MavLink and MP.
  5. Reconnected USB and received a USB overload on you MBP.

I think that your problem with the APM using the UBEC on the APM servo output power bus is the fact that the voltage available to the processor through J1 is around 4.99vdc or less with the peripherals attached. The APM processor really needs around 5.25vdc to work correctly especially with the telemetry radio attached to the APM. To correct this issue I suggest that you use the UBEC to power the APM on its input bus power rail so the full 5.27 vdc is available to the processor and peripherals.
When you then tried to power the APM using the USB with all the peripherals attached except for the telemetry radio, you received an overload condition message from your MBP. To correct this issue I suggest that you try using a powered USB Hub to power the APM and its peripherals (minus the telemetry radio) and see what happens.

TCIII ArdurRover2 Developer


The above review is correct, with one additional step:

  • Removed all peripherals and J1 and powered via USB, same as step 1. 2 Blue LED flashes then fade out, no communication with MP.

I will attempt powering from the input rails tonight, however since I cannot connect via USB like I initially could I’m concerned the chip is toast.

Thanks for the help so far!