Servers by jDrones

APM Rover AUTO MODE

Can someone help me please ?
I have a apm, and I’m trying to set it on a rover, I’m riding (stand) I set everything right, following the wizard, but when I select the AUTO mode it does not follow the waypoints that have been loaded, the platform if you want to move, when put in AUTO, I noticed that the monitor the way back to HOLD. Will you help me?

@Wilyan Arruda De Araujo,

We need more information to help you resolve your issue:
What version of the APM are you using?
What version of the ArduRover firmware are you using?
Are you using a servo for normal front wheel steering or skid steering?
Does your rover move correctly in the Manual Mode?
Regards,
TCIII AVD

@TCIII

Hello,
I am using a 2.5 apm .
My rover uses a drive system for treadmills, not servant .
I can rather move in manual mode. However the self not. I am Brazilian , every text you send 'm translating .

@Wilyan Arruda De Araujo,
Sounds like you are using skid (differential steering).
What do you have SKID_STEER_IN and SKID_STEER_OUT SET too?
What is the type of your ESCs?
I assume that you are using the Elevator (Pitch) joystick for forward/reverse speed and the Roll (Aileron) joystick for steering right and left?
You might try checking the Roll axis “reverse” box in the Mission Planner Radio Calibration screen to see if that helps your issue with the Auto Mode.
Regards,
TCIII AVD

@TCIII

in SKID_STEER_IN it is 0
in SKID_sTEER_OUT it is 0

I am using a Sabertooth 2x12 R/C
My radio is a Turnigy 9x where use channel 1 and 2 (MODE 1)

@Wilyan Arruda De Araujo,
Do you have a motor driving each side of the Rover?
Does each side of the Sabertooth ESC drive one motor?
How do you have the switches set on the Sabertooth?
The SKID_STEER_OUT parameter should be set to 1.
Regards,
TCIII AVD

I used before the sabertooth only with the radio receiver, and it makes even the directions mix as the data it receives. It has more keyswitches never changed.

@Wilyan Arruda De Araujo,
You cannot use the Sabertooth ESC in the mixing mode when it is attached to the APM.
The ArduRover firmware will do the skid steering mixing so the Sabertooth ESC should be setup as two independent ESCs, one for each motor.
Regards,
TCIII AVD

@TCIII

more if the problem is in the sabertooth , because in manual mode works normally?

@TCIII

and when I put in AUTO mode via the computer I see where it appears the level, altitude etc … What it will automatically from pro HOLD mode. In short, I put in AUTO goes to HOLD.

@Wilyan Arruda De Araujo,
It can go into the HOLD Mode for any number of reasons:
Loss of R/C signal
GPS has insufficient satellites and a large HDOP
No programmed waypoints
What do you have the MIS_RESTART parameter set to?
Please provide tlogs and dataflash logs to help troubleshoot your issue.

Regards,
TCIII AVD

@TCIII

In MIS_RESTART is 0
I clicked on to get the latest logs, and created some files in the log folder, I will compactei, and carried on a download server, follow the link: http://www.mediafire.com/download/p8do8jgu8izwqvd/ultimos_logs.rar
If not for what you need, please communicate. Thanks for listening.

@Wilyan Arruda De Araujo,
MIS_RESTART should be 1 or the Rover firmware will keep trying to start over from the last waypoint that it reached rather than starting over at the first waypoint.
I would prefer that you use Google Drive for the tlogs and dataflash logs if possible.
Also, please provide pictures of your setup and the hardware that you are using and how it is connected to the Pixhawk.
Regards,
TCIII AVD

Google Docs: https://doc-04-c8-docs.googleusercontent.com/docs/securesc/foj91akrqdn757nji4b2m51cer8c4btp/le233bgu8dhd63pmjsfgtmdmd4i6o5o7/1459778400000/00362366376776362221/00362366376776362221/0B-Cfyt5REX6IX0lseEgzVVhuZ0U?e=download&nonce=q8p2dafkkb328&user=00362366376776362221&hash=8dtcdu2s8kk7d509c9le6nktpskq2tmp

Hi Willyan. I’ve looked at your log file and the parameters.
BATT_CAPACITY is set to 14? This should be set to the mAh of the battery - the default is 3300.
You have FC_GCS_ENABLE set to 1 which is fine but if you don’t have your GCS connected and running all the time the Rover will be in failsafe constantly. Just wanted to make sure you are always using your GCS.
You don’t appear to have gotten GPS lock from you log. Without a GPS lock the rover won’t know where to go.
I suggest going through the rover setup pages slowly and carefully again.
http://ardupilot.org/rover/docs/apmrover-setup.html
Thanks, Grant.

Hello @gmorph
thank you for attention.
I made the change in parameters.
Could you tell me what is GCS? I half lay on the subject: /

@TCIII
thanks for the help.
The following photos you asked me.

https://doc-0c-c8-docs.googleusercontent.com/docs/securesc/foj91akrqdn757nji4b2m51cer8c4btp/01fi6n170ti6g65rqbcgji4urb4c8df1/1459857600000/00362366376776362221/00362366376776362221/0B-Cfyt5REX6IZ1ZzeFJXRlBIZk0?e=download&nonce=pgvi6pb1aa16q&user=00362366376776362221&hash=uekkfrbtgps0adk5jtp22q7n51i8fe5m

https://doc-10-c8-docs.googleusercontent.com/docs/securesc/foj91akrqdn757nji4b2m51cer8c4btp/3fqeg386mo9id3bje7qa26o28754cqf7/1459857600000/00362366376776362221/00362366376776362221/0B-Cfyt5REX6INzQtYkxuY1JBZjQ?e=download

@Wilyan Arruda De Araujo,
Neither of your photo links work.
Could you just upload them as attachments?
GCS=Ground Control Station, ie: Mission Planner
Regards,
TCIII AVD

@TCIII

sorry friend, was not accustomed to using the Google Drive tool, the internet in my area is a little bad, I tried to attach the image here however unsuccessfully … Follow the links of the images again, if not, please inform me .

https://drive.google.com/file/d/0B-Cfyt5REX6INzQtYkxuY1JBZjQ/view?usp=sharing

https://drive.google.com/file/d/0B-Cfyt5REX6IZ1ZzeFJXRlBIZk0/view?usp=sharing

@Wilyan Arruda De Araujo,
Thanks for the pictures. Unfortunately they do not do much to help understand your setup and the issues that you are having.
Have you tried running in the Auto Mode since making the corrections suggested by gmorph?
Regards,
TCIII AVD

Servers by jDrones