APM PLANNER v2.0.19-rc3 - blank HUD

I’ve downloaded latest sources (branch: video-wip) and compiled them.
Now my version is v2.0.19-rc3 (0d2d5a9c-2.0.19-rc3-26-g0d2d5a9) but my HUD is still blank.


which OS are you using? by blank do you mean it shows a grey back ground? what did you try to test the video locally? The more information you give the more likely I can help. Try not to to write “it doesn’t work”, as that is about as useful as me showing you a picture of it working :wink:

PS: I have merged the changes for 2.0.19-rc4 into the video-sip branch, you should pull them :slight_smile:

Later: I updated the video streaming widget, you should be at SHA fcb7c17.

You may need to delete the libs/lib/Frameworks/GStreamer.framework from the build tree if using OSX and building yourself.

I’m sorry, I forgot some important info.
I use Ubuntu 14.04.3 LTS 32bit and I install gstreamer 1.0 as you describe in the README.MD.
I’ve the newest version which came with a git pull done some minutes ago after your last reply.
As explained in another post to test video on HUD I use this comand:

In the log of the apm I saw another port (14550) and I also try with that.
When I start apmplanner2 the PFD is completely white and i can’t see anything.

And which version of Qt are you using?

I’ve installed the developer environment as described on the guide with tis comand:

sudo apt-get install git qt5-qmake qt5-default \ qtscript5-dev libqt5webkit5-dev libqt5serialport5-dev \ libqt5svg5-dev libsdl1.2-dev libsndfile-dev \ flite1-dev libssl-dev libudev-dev libsdl2-dev \ qtdeclarative5-qtquick2-plugin
Qmake version 3
Qt version 5.2.1
I use a partition of the HDD only for testing APM video-wip.
In this partition I installed only the developer environment and nothing else.

I’ve the same problem on another partition with Ubuntu 14.04.3 64bit.

Hi, you need minimum Qt5.4.2 (I think) for the video-sip branch. I just ran a version now, and the PFD was white, which means the QML failed to load. If the PFD loads, you will have more luck. if the pFD loads and the background turns grey when you select ‘Video’ by right clicking in the PFD view area you should be close to having it working.

I am building and testing a version now on 32Bit Linux Mint 17.1, I just need to download and install Qt5.4.2 on that machine first, and I will report back if it works. (The machine is an old Lenovo T60p laptop, so pretty slooooow :frowning: )

install Qt from here download.qt.io/archive/qt/5.4/5.4.2/

I have it working with the current HEAD on video-wip branch. Qt5.4.2 is the new minimum version required. (we use Qt5.4.2 for OSX builds)


Qt5.5.1 also works OSX and Linux x64, but have yet to test Qt5.5.1 on x86.

NOTE: when using an installed version of Qt you need to configure the Kits and Qt Versions (you don’t need to worry about the command line settings unless you are building on the command line)

also you can use the newer version of QtCreator by starting it in terminal using

e.g /opt/Qt5.5.0/Tools/QtCreator/bin/qtcreator&

If you do that it should auto detect the correct version for that QtCreator (though you can add other Qt Versions)

It’s ok, it works fine in Ubuntu 14.04 32&64bit with Qt5.4.2.
My problem now is to get the video from a converter RCA to USB but not H.264.

built current video-wip on Ubuntu 15.10 , Qt5.4.2

  • running gst-launch-1.0 videotestsrc ! x264enc ! rtph264pay ! udpsink host= port=5000
  • the primary flight display checnes to gray only, no video inside, no clue in console.