Servers by jDrones

APM planner 2, not working with macOS Mojave or Sierra

Hey all,
Im new to Ardu pilot and APM planner 2. I have downloaded and installed the application to both my MacBook pro and iMac to receive an error message saying “this application is not compatible with my current version of OSX”

My iMac is running macOS Mojave 10.14.4, and
my MacBook is running macOS High Sierra 10.13.3

Has anyone had a similar issue, or know of a way around this? T.I.A

Hi, I am using APM Planner v2.0.27-rc1 and it is working very well on my MacBook Pro 13 Mid 2012 running macOS Mojave 10.14.4.

http://firmware.ardupilot.org/Tools/APMPlanner/beta/apm_planner_2.0.27-rc1_osx.dmg

Running MacOSX 10.14.6 MacPro latest apm_planner_2.0.27-rc1-7-g299ff23_osx
10.11.6 on a MacBookPro apm_planner_2.0.27-rc1-7-g299ff23_osx
10.8.3 on a MacBookAir apm_planner_2.0.18-rc1_osx

There must be another issue causing the problem.

Thanks @winstonsaz, the download in your link worked perfect.
For some reason i was unable to find that on the ArduPilot website myself.

Hey, @winstonsaz do you have any advice on starting up the APM planner with a pixhawk flight controller using base corrections? Im following the instructions in this link, though similar these are for the Mission Planner software and isn’t working for me.

https://docs.emlid.com/reach/ardupilot-integration/

My most sincere apologies, but I have no experience with that topic.

@jimmymyres the passthrough is not implemented in APM Planner only in Mission Planner.
Not sure about QGC but I don’t think so.
So Mac is not supported for this application.

Servers by jDrones