Servers by jDrones

APM Planner 2 / Mission Planner - Motor Test

I’m trying to test motor rotation and speed but nothing I do will get the Pixhawk to play ball

In mission planner I get

“command refused by autopilot”

In APM Planner 2 I can’t even find a motor test facility and the terminal window won’t work at all - just screen full of rubbish - wrong baud rate ? - but doesn’t work regardless of baud rate even after a Pixhawk reboot.

I’ve disabled pre-arm checks but still I can’t get the motors to spin up.

The only thing this can be related to is that I haven’t yet calibrated my receiver / transmitter - (since I’m still waiting on the receiver to be delivered). Even so I’d have expected some way to bypass all safety’s so that I can spin up motors,

I’ve set RC1 to RC3 min max and trim values to what I get on my X650 using my Futaba transmitter / receiver.

How can I get my motors ‘tested’ - is there some option or parameter that I’ve missed ??? – if not can one be made available to force the Pixhawk to allow motor test from mission planner.

I want to

a) Check rotation
b) Verify motor numbers are as the Pixhawk expects for a Hexa - which are different to DJI NAZA.
c) Verify motor RPM for any given ‘percentage’ i.e. on my 920kv motors that’s 5500 or so for 50% on 12VDC

I don’t want to be forced to calibrate a transmitter / receiver to do this

Hi,

Unfortunately the terminal motor test requires a previous calibration of the RC since it uses the throttle calibration to operate.

I’m not aware of other way to test the motors. I’m sorry.

But I’ve set calibration values that I anticipate on the RC3 parameters - surely this is enough - since RC3 is throttle …

Given that the data is via communication anyway and can be any number I decide - since my transmitters a Taranis and also open source - I can program any values for a channel output …

A numbers a number - doesn’t matter if it came via a transmitter or not, at the end of the day if the parameter is set that should suffice. I’ve looked through parameters.h and see no other parameters / flags that indicate the calibration is even completed via transmitter or not, really didn’t want to dig so deep into code so early.

What version of AC are you using? 3.2 has terminal removed, 3.1.5 has terminal, but it only will,work within the first 30s for safety. You need to press enter 3 times to engage the terminal montior.

The other thing, is that you need to calibrate your radio, then calibrate the ESCs, before you can reliably start yor motors.

See Copter.ardupilot.com for more intructions

I’m using 3.1.5, I’ll try the terminal thing, and 3.2, but for me there is a number of issues with the requirements just to arm the motors.

1 : The ‘calibration’ values are simply entered into parameters - this I have done manually because the receiver is yet to be delivered, RC3 in particular was given an appropriate range. In any case the Pixhawk uses communication, it isn’t like we’re calibrating PWM inputs here, keep legacy analogue behaviour out of the digital world !!.

2 : The DJI ESC’s that I have CAN NOT be calibrated, that’s why the 0 to 1000 business on the outputs needs to be managed and verified to get the best / appropriate performance out of the motors although not sure how this bit works. I have seen a number of posts indicating that the output scaling used by the Pixhawk is totally inappropriate on DJI ESC’s.

3 : The Taranis transmitter I have allows me to set whatever minimum and maximum value I see fit to each and every channel so it isn’t too hard to know exactly what my transmitter will be sending - given that it too is open source and I have the code for that too.

It should be possible to test / calibrate and verify control outputs at ANY stage using simulated input regardless of whether the real input is present or not. The motor test should not depend on RC calibrations. If I tell a motor to go to 50% then I want to see it at 50% with no software interference beyond appropriate scaling to map input range onto output range. If the motor at 50% stick then doesn’t match the 50% output expected then there is an issue to resolve, this is also why it needs to be possible to bypass PID’s etc to stop them winding motors up in some vain attempt to level a copter that hasn’t even left the ground - it’s called ground test mode as opposed to flight test mode. I can test the motor using an ESC tester but that doesn’t test the ‘system’.

As for the ‘we removed it for safety reasons’ that is a slippery slope to dulled down crappy software, no matter what you do there will always be a better idiot who will do something really really stupid. At some point you must credit the ‘user’ with having some brains. Providing the ‘facilities’ provided by terminal exist in the APM Planner then good riddance, but if the facilities don’t exist then the terminal should stay,

Sorry if this comes over harsh but I do this kind of thing for a living - partly why I’ve ‘come to play’ with APM / Pixhawk etc etc.

I would suggest starting here to see why your motors won’t spin up. See here for going through pre-arm specific checks for more specific reason why your manual settings are not working.

AC3.3 is targeted to remove the dependency on the RC Radio completely, until then, the mandatory setup procedure being followed is the easiest way to get AC working.

copter.ardupilot.com/wiki/initia … -hardware/

Well I have an update, using 3.2 beta and the motors will spin up, so that’s a result, put 3.1.5 back and they won’t spin up any more so that confirms that one. It was failing on RC not calibrated in 3.1.5 clearly. I still can’t get the terminal window to work in APM Planner but I’ve ticked something off the list at least.

I now need to figure out the outputs being sent to the motors, they won’t start until I enter 35% as a demand, so I now need to understand how the 0 to 1000 business works …

I appreciate the input, perhaps one day I can make some sort of contribution that goes beyond questions - but I need to understand far more than I do now - I’m still very much a noob with APM / Pixhawk.

buenas, tengo este mismo problema y lo he tratado de solucionar de 20 maneras posibles. la ultima es entrar al código fuente, entender como funciona y tratar de buscar donde se origina el error command was denegued by ardupilot.
Si alguien he avanzado al respecto agradecería muchísimo su contribución gracias.

I would think that in 7 years progress has been made :roll_eyes:

Servers by jDrones