APM Planner 2 Adding a new parameter


I recently went through adding a parameter to the AP_Beacon library

However, I can’t see the new parameter in APM Planner 2. How am I supposed to add the new parameter to APM Planner 2?

I moved this to the APMPlanner topic, so the right people can see it (@billb is the Planner guru).

1 Like

AFAIK there is a XML file in the apm planner Directory which describes those Parameters - but I am not sure. Perhaps you have to patch this file.

Yes that’s exactly it. The file is called apm.pdef.xml. I will follow up to see if it works.

Unfortunately the XML file gets updated to its original values every time APM Planner 2 restarts. The top of the file says that the parameters were generated with a script called param_parse.py, but I can’t find that script anywhere.

I don’t know about this script either - perhaps I can show you the place in APM Planner where you can disable the downloading - I will have a look at the code this evening.
Perhaps @billb has another Idea how to deal with this.

I am trying to change the mode of the ardupilot software to the loiter mode. I am controlling the pixhawk using the mavlink protocol. I am able to change the mode to the loiter mode using the mavlink protocol.
Now i want to send the signal to the ground station (apmplanner2 in my case) to give me an alert that the mode has been changed. I know by default thr are some alerts that it will say the mode has been changed to loitor. Are thr any custom alerts/warning messages which i can use? How do i add a customer message on the ground station and send the command from mavlink to hear that alert?

Thanks in advance for the help!!