APM Planner 2.0.24 on Win10 3D Accell calibration - no prompts

Hi I have an eBay APM 2.8 and am trying to set this up using APM Planner 2.0.24 on Win10.

If I connect to the MAV001 and wave it around the artificial horizon responds to I think that the device is OK.

When I try the 3D Accelerometer calibration I get the count down but no prompts. Most of the older posts online suggest the CLI but this has been removed from this version.

Any ideas?


OK ‘Marooned’ tried this and went back to APM 1.x. I tried APM 1.39 and this seemed to work fine.

Soooo… my question is: Are there any issues using APM 1.39 to set up the device and then switch to APM 2.0.24 for flying?

Is the calibration done on the Arduino side or is this saving calibration data in APM?


All the data is saved to the flight controller. You should be fine using the latest APM Planner for flying.

Thanks carpy. 'll set up on the old version then.

One slightly odd thing though. on APM 1.39 if I manhandle the FC through a ‘loop’ the artificial horizon follows it round OK.

If I disconnect in the FC and reconnect in APM 2.0.24 and then do the same the artificial horizon goes inverted and then hangs. In fact the whole application hangs and has to be restarted. Any ideas why that is?


Hmm…maybe I spoke too soon. Where did you get APM 1.39?

I google led old versions of APM mission planner and ended up at the archive page:


Ok, that makes more sense.

That’s Mission Planner and I thought you were talking about APM Planner 2–two different products.