APM Planner 2.0.23-rc4 broken on Mac OS X 10.12 AC 3.4-rc5

I have been working on earlier versions of Mac OS X in the work shop but was having trouble downloading firmware so decided to use the office computer which is now on OS X 10.12 Sierra.

I was able to download Copter 3.4-rc5, although very slowly, and it installed.
Powered everything down and then went to calibrate the sensors.
And this is where things stop working.
I have quit APM Planner and powered down the Pixhawk a few times but still the same results.

  1. Initial setup/Frame type - Y6B is the only selectable frame type even though Octo firmware was installed.
    Download Parameter/Refresh and nothing happens, list appears empty although 3 blank lines can be selected.

  2. Compass Enable and Auto declination greyed out and manual field not selectable.
    Live calibration fails with ‘Not enough data points collected’ tried 3 times, same result.

  3. Accel Calibration- Calibrate MAV007 Time remaining until timeout countdown with no other buttons.
    Clicking Calibrate Accelerometer just resets counter.

  4. Flight Modes - selected 6 flight modes and clicked ‘Write’ with the bar graph staying at 0%.
    Usually moves to 100% when written.

At this point I decided to try and reload the firmware.
Same result.
Reloaded Rover to erase everything and tried Compass calibrate, same result.
Reloaded Octo just make sure it was not a bad load, the download takes over 3 minutes. It’s never been this slow before.
Same result.

In the end I used Fusion and Mission Planner.

It seems the problem was caused by changing the MAVid to 2

This is causing multiple issues with connections even though you can reload firmware it does loses the MavLink connection when you try to connect.
Erasing (by loading Rover or other type) does not seem to erase MAVid.

This is fixed in AC3.4 stable release

Confirmed, no longer an issue.