APM PLANNER 2.0.19RC-2 - getting the HUD working

I saw post on diydrones that was removed on getting the hud working in apm planner.

If anyone has it working can they share how they got it to…

I installed from scratch apm planner with gstreamer1.0 and
its libraries and confirmed that on qmake it was being built with video.

I don’t see any options for entering gstreamer commands in apm planner?
The cached link I found says to enter:
gst-launch-1.0 videotestsrc ! x264enc ! rtph264pay ! udpsink host= port=5000

I did this via terminal in the background thinking maybe it would work(I entered my own IP address)

I am using a raspi on the other end and can confirm that I have gstreamer working
entering a different command but I would like to have the video show up with the HUD.

Any tips would be helpful

You can build it from source using the video-wip branch from here github.com/diydrones/apm_planner/tree/video-wip

I had a problem with the builds (windows/osx) (one being it was really two large for our download packages!) I need to work on it to fix it so it can be dependent on if the user has gstreamer installed or not. You need to install gstreamer on your platform for it to work.

You just need to enter this on the rapsi

This code was for testing on the desktop (and it also verifies you have gstreamer installed correctly on the desktop

Hope that helps :slight_smile:

Hopefully I have some time to fix the builds soon so we can release this to the larger public. (That said I may do a handbuilt bundle for OSX to see interest)


Thanks for help…I will rebuild with the wip branch.

How are you connecting raspi and gcs? 4G?

I have wifi - so I’ll have to change the udpsink host part but as long as ports are right no prob?

Are you entering the desktop gst-launch into apm planner or in the background in terminal? Maybe it will be more clean once I build the wip branch


the gst-launch instruction for testing is on the desktop. It sends data to local host on the port APM Planner is listening on.

We github.com/diydrones/apm_planne … /README.md for more info as well

I’m still having problems…I did the sample gst-launches where it opens a ball(in separate window) but it is never opened in the apm planner regardless of what ip/port i use

also the primary flight display is blank.

I am struggling to see what to do once I have apm planner running.

You need to right-click in the PFD and select Video drop down menu option.

The port is 5000. see github.com/diydrones/apm_planne … ML.cpp#L78

The ip when run on the same machine needs to be the loopback ip of

I don’t have right click abilities on the PFD? Nothing happens when I right click

In the top drop down menu also in adv. mode I don’t see video mode either.

In the terminal where apm planner is running I do see this happening:


not sure what is wrong with my setup. When I ran qmake I saw that it was built with video support and I have all the gstreamer packages.

Hi, I just updated the video branch with master and tested with Xubuntu 15.04 and it worked. Try updating the branch and rebuilding.


Did you commit your changes… I don’t see them

I just pushed them to remote now. I forgot earlier, d’oh. :geek:

I’ve the same problem: my HUD is blank.
I download the project today but nothing has changed.
I’ve installed it on a PC with Ubuntu 14.04.3 32bit and on the same PC with Ubuntu 14.04.3 64bit with the same final result.
Before compile the entire project I’ve installed gstreamer1.0* and libgstreamer1.0* as you suggested in your readme file.
Another strange thing has happend: when I’m trying to connect my pixhawk (with no calibration) APM crashes.
What’s wrong?
What can I try?


2.0.19-rc2 won’t work, you need to compile the latest code. I wil remove them from the downloads section