APM Planner 2.0.18rc1 Mac OS USB Connection Issue

Using 2.0.18rc1 on my MacBook Pro (a rather old 2009 one, but running Yosemite), and whenever I connect to my Pixhawk (AC 3.3rc5, fresh install starting with factory defaults because I switched between frames) via USB, I get a good connection for a few seconds (like less than five), and then the GCS tells me “link lost for System 1”. The little green connection button doesn’t change colors, but I am no longer getting data at the GCS. Never had a problem until this version. Via 3DR radio the GCS and Pixhawkconnect just fine and stay connected, but not via USB.

I’ll test, but did you try a different USB cable?

I have had it connected for the last 12Hrs and it’s still connected 10.10.3.

Try reinstalling the FTDI drivers, but follow this guide, as it removed the old install first.

ftdichip.com/Support/Documen … AC_OSX.pdf

This has worked for another person in the past see viewtopic.php?f=82&t=11781&start=20#p32993

I am seeing the exact same issue
2 different Macs 10.10.3 and 10.6.8
APM 2.6 on different machines
APM Planner 2.0.17
Different cables

Did you try the USB driver uninstall reinstall and 2.0.18-rc2 builds? Thx

I have just tested this and it works with APM 2.5/2.6 on 10.10.3 with 2.0.18-rc2

It was indeed the Drivers.
Updated the OS10.10 with the appropriate drivers and now it works well, while in the foreground.
If it is in the background it loses comms for 10 sec at random intervals.
No big deal, as it always reconnects OK.
Re-did the drivers on the OS 10.6 machine and it is now behaving itself.
Not sure why that happened as it had been working in the past.
But all good now