APM planner 2.0.18 "standard params missing" MAC O/S

Hello All,

APM planner was working fine, then today when i connected to the APM all screens were available except for the standard params screen which was empty even though in the bottom left i saw it downloading params… I read different versions of similar issues but just can’t correct it, i have rebooted the aim rebooted the MAC etc etc and the params just don’t appear. I used to see a message pop up when i booted up APM planner saying a later version 2.0.20 was available but that happen now as i was wondering if an APM planner upgrade might fix it. I have also gone into the help screen and done search for updates with no luck , nothing seems to happen.

tried upgrading to apm planner 2.0.20 march 16 2016 , downloads ok but on installation it always say version 2.0.18 ?? checked download file “apm_planner2_latest_osx-2.dmg” and it says date modified 25 july 2015 ???

What version of ArduPilot FW are you using. I think it maybe related.

It wasn’t working yesterday and today I sat down to look at a fix, and it was working again. I think I know what the issue is, but you should be ok for now.

Hey Bill. Does it have to do with none of the new builds showing up on http://firmware.ardupilot.org/Tools/APMPlanner/?

The issue is to do with the apm.pdef.xml download not being available. I think the error case is OK when the network is nt available and it reads the cached version from ~/apmplanner2/ dir. The problem is when the file is available, but redirection fails. (its an edge case relates to the moving from .com to org) it should work again now but should be fixed

Roger. :slight_smile:

I’m running 2.0.20 on OSX and I cannot see Advanced Params or Standard Params. Any ideas?

I’m using ArduPilot 3.2. I had to downgrade from 3.2.1 because telemetry was not updating.

Hi Bill,

I have internet connectivity and I am unable to see the standard params or advanced params.

Is there a workaround?

Disconnect you network, and see if it works?

Hi Bill,

Thanks for the response. I turned off my wi-fi and restarted APM planner 2.0.20 and did not get the standard params or advanced params screen. I don’t have access to a Windows machine at the moment. I may get a chance to get my hands on one in a day or so.

FYI, I’m running OSX 10.11.3 El Capitan and running Ardupilot 3.2 on the FC.

Thanks again.


I’ll see if I can replicate. The last time I tested the this a week or so ago it was working. I just need to figure out what the issue is. Thx

I have exacly the same problem. FW arducpter 3.3 and I cannot see standard/advanced params.

File ~/apmplanner2/apm.pdef.xml has 302 redirect so is broken. I will check after work if download again help.

File is in http://autotest.ardupilot.org/Parameters/apm.pdef.xml location. So if anybody want check this may help:

rm ~/apmplanner2/apm.pdef.xml; curl ‘http://autotest.ardupilot.org/Parameters/apm.pdef.xml’ -o ~/apmplanner2/apm.pdef.xml

Thanks for your quick answer to my post Missing advanced parameter list in apmplanner 2.0.18 .
I’ve tried with the downloaded but, no changes, only when switching between installation at the first run of the new one, the list full parameterlist is accessible and the parameters are visible. Standard and Basic are empty.

OK, try this:
close apm planner, go to terminal:

rm ~/apmplanner2/apm.pdef.xml; curl ‘http://autotest.ardupilot.org/Parameters/apm.pdef.xml’ -o ~/apmplanner2/apm.pdef.xml; chmod 400 ./apmplanner2/apm.pdef.xml

I need add chmod 400 because apm planner always downloading wrong file:

302 Found


The document has moved here.

Apache/2.4.7 (Ubuntu) Server at autotest.diydrones.com Port 80

@billb always when i open apm planner Im getting this file, I completly remove apmplanner2 directory but not work. Only works when I download file from url and add chmod 400 - apm planner dont have write permission so file is good

Thanks. That explains the errors people have been seeing. It must be that the permission on the server have changed when it moved.

No, I added this permission to file to prevent file updates. Problem is that apm planner when start always write file with wrong body - see my above post (with 302 redirect).
So probably Your download lib in app not follow with redirect and put wrong body to file.

Ok, I understand the issue, but 2.0.20 should fix the issue and avoid the redirect


Unforutnately not, I removed current apm planner, downloaded new from Your links, removed apmplanner2 directory and after run new version apm planner file is broken.

Debug console output:


I grep apmplanner2 binary in Contents/MacOS/ and looks like wrong address is here:

is http://autotest.diydrones.com/ and should be http://autotest.ardupilot.org/

If You need any aditional data feel free to notify me.

Thanks for the detective work. I honestly thought I had changed that. I send out a fix