APM Planned Mission Corrupt when opening in Mission Planner

Ran into a snag yesterday. I created a simple 10 point circle area using the Mission Planner software and saved to my computer. I then opened in APM and made some modifications then resaved it over the existing file. When I went back to the Mission Planner software, the application stated that the file was unreadable.

Why is the two programs not cross compatible when working with mission plans?

Is anyone esle having the same issue?

Doug W.

Can you post the file?

See attached files.

The original file (MP Test.txt) has not been opened in APM Planner. Created in MP only.
The “MP Test APM” was the “MP Test.txt” file opened in APM and then saved with no modification at all.

Mission Planner (V1.2.99.2 build 1.1.5204.13817)
From the Flight Plan window I selected "Create WP Circle. I accept all default options and plotted 20 points. I then saved it as “MP Test.txt”.

APM Planner (v2.0.8)
From the Flight Plan window I selected “Load WP” and tagged the “MP Test.txt” radius file. After verification that the file loaded correctly, I selected “Save WP” and saved as “MP Test APM.txt”. Nothing was modified prior to saving it.

Mission Planner (V1.2.99.2 build 1.1.5204.13817)
I closed Mission Planner and then restarted it to ensure a clean application with nothing displayed in the Flight Planner window. From the Flight Plan window I selected “MP Test APM.txt” file and upon it attempting to load received “Invalid Waypoint file” message.

The reason is that Mission Panner will not load a WPL marked as version 120, only ones marked 110. I have added fix that will be in the next release on AP2.

In the meantime, you can just edit line#1 of the waypoint file. to read QGC WPL 110

I’ll await the fix. Thanks for looking into it.

Has this discrepancy been assigned to GitHub for correction or has it been fixed already?

Its been fixed. :slight_smile:

Great thanks. I didn’t see post stamped [SOLVED] so I figured it was still outstanding/open.

That solved is for you to set when you feel the post was answered.

I was not aware of that. Thanks. I will change the status then.