Servers by jDrones

APM:Plane 3.0.3 released


(tridge) #1

The ardupilot development team is proud to announce the release of
version 3.0.3 of APM:Plane. This release contains some important bug
fixes for all supported boards.

The key bug fixes in this release are:

  • fixed handling of filter divergence in the EKF filter
  • fixed a glide slope calculation bug when entering AUTO mode

The EKF fixes are the main focus of this release. During testing of
APM:Plane with the AHRS_EKF_USE enabled it was found that under some
circumstances the EKF could diverge, resulting in loss of attitude
estimate. Unless the pilot quickly took control in MANUAL this could
result in the aircraft crashing.

The fix for this problem was in several parts. The main fix was to
prevent the divergence, but as a precaution against future bugs of
this type additional numerical checks were added to allow the EKF to
automatically reset in flight when the internal state shows
large gyro bias changes, which are the first sign of something going
wrong in the filter. If this happens again the EKF will automatically
disable itself for 10 seconds, allowing APM:Plane to fall back to the
old DCM code. The EKF will then reset itself using initial state based
on the DCM state. The aircraft will report the failure using the AHRS
health bit in the SYS_STATUS MAVLink message.

The default EKF tuning parameters were also updated based on a number
of user supplied flight logs to increase the robustness of the filter.

The second bug fixed in this release relates to the glide slope
calculation when the aircraft enters AUTO mode for the first time when
at an altitude above the altitude of the first waypoint in the
mission. The starting point for the glide slope was incorrectly
calculated using the home altitude, which resulted in the aircraft
descending below the first waypoint altitude before climbing again. In
some circumstances this could lead to a crash due to local terrain.

Many thanks to everyone who tested this release. Special thanks to
Dellarb for reporting the glide slope bug and to Paul Riseborough for
all his work on the EKF code over the last few weeks.

Happy flying!


(hxxnrx) #2

Hi Tridge,

thank you for this release. Good work.

But what about the fix for the ETS airspeed sensor? I think the Pixhawk platform is also affected by this issue.

Eagletree Airspeed sensor V3 on PX4IO

Regards
Hxxnrx


(tridge) #3

Hxxnrx,
Sorry for missing this patch for the release! I’ve pushed it to PX4Firmware now and it will be in the next release, or you can get it in ‘latest’ now.
Cheers, Tridge


(Andre-K) #4

Thank you :slight_smile:


(afishindouban) #5

thanks a lot, even it is little bit late. I noticed the second problem these days. I was using 3.0.2 and when I switched to auto, airplane started to decent from around 100m to 60m and crash to a tree. It took me one day to repair the pane and lost some small parts. :slight_smile: need to be careful when I make plan later, don’t be close to the trees… even you are higher…


(cala2) #6

I’m near winter and bad weather to fly but yesterday was a nice day and I can fly my Skywalker 168 with APM2.0 and 3.03 firm; FBWA perfect, mission changing altitude between waypoints just impressive perfect :astonished: , loiter and RTL well too. Thank’s for this great vers :smiley: .
APM 1 with SW 1900 doesn’t work well but perhaps it’s time to update the APM. :wink:


(govsux) #7

Well I took the plunge and upgraded from 2.72! I can’t wait to try it out this weekend. I think my little old fashioned APM 2.5 even looks a bit shinier now :laughing:

Is there a tuning guide? I noticed ‘auto tune’?? I know copter had this but does plane now too?? Also I will be mothballing my old MT gps but for now that’s what I have. 3.0.3 okay with that older gps?

side note… I had a connection problem with mavlink with 2.72. Only in auto mode… go figure. Anyway that problem is gone with 3.0.3 :smiley:


(StefanG) #8

plane.ardupilot.com/wiki/automat … -autotune/


(RC Mike) #9

3.0.3 flies very will - thanks for all the hard work.

Are their any plans to add rudder to Autotune in the future? I can tune it ok manually but it’s fairly time consuming. Rudder Autotune would be a nice enhancement.

.


(RC Mike) #10

I got everything hooked up to my 14SG transmitter using a 7003SB telemetry receiver and it looks like everything is working correctly. The only thing I can’t figure out is how to calibrate channels 9 through 12. Please give me a hint.

I will be using channels 9 and 10. I assume that if I set them to pass through they will come out auxiliary outputs 1 and 2. Is that correct?

.


(govsux) #11

I just replaced and amp 2.5 with a pixhawk and now seem to have a strange issue where upon restating the pixhawk the roll pid is zero! I discovered this by setting the mode stabilize and noticed the controller does not make any adjustments for roll. I looked in the ‘tuning’ tab in APM Planner and sure enough it’s at zero. I changed it to 1.000 all is well until the pix reboots then it’s again lost!! I connected to another computer and this time used MP… set it back to 1… save… but again upon restart the roll pid is zero! :astonished:


(govsux) #12

Update… Seems fine now. Not sure what was the problem. Only thing I know I did for sure was change another pid after setting the roll pid to 1. Seems like sometimes it didn’t remember the very last thing I sent. Bad mavlink maybe? Baud rate was at 57600 though and seemed good. Just a gremlin I guess. I’ll take a gremlin on the workbench any day over a gremlin in the air :]


(Elvis) #13

I just upgraded my Pixhawk to 3.0.3 and now I can’t get telemetry data to show through my Minimosd. I get “No Mav Data” instead. Tried the “Enable Telemetry” button on MP, and also tried resetting to SR parameters to previous configs all with no luck.
Any ideas?
Thanks,
Elvis


(Apmflight) #14

[quote=“tridge”]The ardupilot development team is proud to announce the release of
version 3.0.3 of APM:Plane. This release contains some important bug
fixes for all supported boards.
Happy flying![/quote]

Thank you gentlemen for the new version 3.0.3. !
It would be great if in the future there is the possibility of implementing something like “Thermal Scan” mode, “ThermoPilot” mode.
github.com/jlnaudin/x-drone/wik … Pilot-v7.2

APM Plane is awesome!

Julian


(astrojohn) #15

Hi,

Does this version have the external GPS Lock and status LED capability now?

Does this also run on the APM2.6 hardware? As it does say that the Pixhawk has the require floating point.

regards,

John


(govsux) #16

Can APM Plane use RX throttle failsafe with a nitro engine plane without shutting off the engine upon a throttle failsafe event?

if not…
I would like to see this implemented in APMplane as an option for nitro user with TX radios with only a throttle failsafe upon TX loss of signal to RX.

It would seem possible to have a selection for apm or pixhawk to not immediately reduce the throttle but instead go to cruise throttle and RTL. If I understand how it works now it can go to RTL but only after killing the throttle? This doesn’t work for a nitro plane users as it cannot restart and then do RTL. Perhaps this could be a part of the throttle pass though option currently available? If the lowest ppm value set during radio calibration is say 900… couldn’t it decern an instant lower value set from the RX throttle failsafe as a RX failsafe event and not a TX induced throttle request? … thus THEN determine through a few parameter settings if it should in fact kill the throttle or… as I am suggesting go into a designated mode [ RTL, circle, ect ] with throttle at the current or preset trim throttle before actually dropping the throttle so much it kills the nitro engine? Or… is this already possible and I misunderstood how it works? I attempted to set up throttle failsafe and it seems like it simple kills the throttle.


(futurebreeze) #17

[quote=“Elvis”]I just upgraded my Pixhawk to 3.0.3 and now I can’t get telemetry data to show through my Minimosd. I get “No Mav Data” instead. Tried the “Enable Telemetry” button on MP, and also tried resetting to SR parameters to previous configs all with no luck.
Any ideas?
Thanks,
Elvis[/quote]
A friend of mine experienced the same thing last week, he has a Pixhawk board with the latest firmware APM:Plane 3.0.3 and the tried to make a quick setup on the bench (no plane or multirotor involved so far). The MinimOSD displayed just the “No MAv Data” message. After many unsuccessful tries my friend uploaded APM:Copter and surprise, the OSD came to life again, all the data appeared on screen. He concluded that APM:Plane 3.0.3 on Pixhawk board just don’t stream out the right type of data that MinimOSD (regular,not extra) expects.


(Elvis) #18

[quote=“futurebreeze”][quote=“Elvis”]I just upgraded my Pixhawk to 3.0.3 and now I can’t get telemetry data to show through my Minimosd. I get “No Mav Data” instead. Tried the “Enable Telemetry” button on MP, and also tried resetting to SR parameters to previous configs all with no luck.
Any ideas?
Thanks,
Elvis[/quote]
A friend of mine experienced the same thing last week, he has a Pixhawk board with the latest firmware APM:Plane 3.0.3 and the tried to make a quick setup on the bench (no plane or multirotor involved so far). The MinimOSD displayed just the “No MAv Data” message. After many unsuccessful tries my friend uploaded APM:Copter and surprise, the OSD came to life again, all the data appeared on screen. He concluded that APM:Plane 3.0.3 on Pixhawk board just don’t stream out the right type of data that MinimOSD (regular,not extra) expects.[/quote]

Yea, it works fine with my arducopter release as well. I’m sure it’s something with this release (arduplane 3.0.3). Not sure what they did but it stopped working after 3.0.1.


(gti_uk) #19

right ive tested this twice today, i had 3.0.3 installed on my PIXHAWK and i get the no mav message on the on screen dispaly, i then rolled back to 3.0.1 and i got data on the osd as expected. i then went back to 3.0.3 and again no mav message. So lastly ive gone back to 3.0.1 as its quite useless to run 3.0.3 without the osd working bugs or not.

before anyone says its working on theirs are you running APM2.5 or Pixhawk?


(FabFlight) #20

I’ve read the autotune documentation but can’t turn the function on because “autotune” is not one of the flight mode list in Mission Planner 1.3.7. Have I missed something ?

plane.ardupilot.com/wiki/automat … -autotune/

Thanks.