APM not responding

Hi Everyone

when I fly my quadcopter and the battery gets low the APM stops receiving commands and, the quadcopter continues to hover in fact it goes slightly high about 10 meters then it stays there until the battery runs out.

I have only tested my quadcopter twice and this happened twice, the first time it did my quadcopter ended up 15 meters high on a tree :unamused: I replaced the board after that incident and used another brand new APM and today as I was flying it and around 25min into the flight just when the low voltage alarm started beeping I suddenly lost control and quad went slightly high around 10 meters then kept hovering until it landed and the props were off so I quickly ran to the quad to disconnect the power but suddenly it started working again but I managed to unplug it "one of the props managed to hit my hand :neutral_face: "

the transmitter has new batteries and its working as it should be, this issue is really bothering me :cry:

I am powering the APM using a power module and the receiver is powered from the apm, the battery voltage never went below 10.4v its a 3S Lipo.

the version is V3.1.5

your help and advice is much appreciated :slight_smile:


Providing either tlogs and/or data flash logs will greatly aid with troubleshooting your issue.


many thanks for your quick response !

I have attached the logs, if you have a look at the gps map the line that goes high then drops was when the battery was low.

since that flight I attempted another but I disabled all/any failsafe settings that were enabled I think the battery failsafe was on, after disabling them I tried another flight which seems to have worked but then again I didn’t fly till the battery was too low instead I flew for about 6 minutes then tried to hold the quad till the battery ran out it seems to be responsive after the disabling the failsafe. could kindly view the logs and see if that indeed was the cause of the non-responsiveness or could it be something else ?

Best Regards,

aha ! just had a better look at the google earth logs, it seems when it lost control it was in RTL mode so failsafe kicked in and put it in failsafe mode and thats why I lost control, could that be it ?